Community Forum

X1 box issues

Regular Visitor

X1 box issues

I have to unplug and reboot the box every time I turn on the TV.  Usually, it just skips during play or recorded play. This time, I had sound and no video until I did a reboot through the Comcast page, Has anyone replaced this awful equipment yet? And what did you get instead? Is FIOS any better?

Gold Problem Solver

Re: X1 box issues

You might want to consider having Comcast send a tech out to investigate.

X1 boxes have proven to be extremely signal sensitive and they require really good signal levels both incoming and outgoing. My 3 X1 boxes work perfectly but my signal levels are well within X1 specs.
Regular Visitor

Re: X1 box issues

Thank you for your response. I have done all of these things, including having a tech out to check the signal, replace cable connections and certify that there is no issue with the wiring. The equipment continues to malfunction and as I read through other posts, this is the rule, not the exception to the rule.
Gold Problem Solver

Re: X1 box issues

Actually I have had X1 service for in two different houses for 5.5 years now and I can assure you that it is very reliable if your signal levels are within spec.

Sorry to tell you this but it would not be the first time that an X1 customer has needed more than one in home tech visit.

X1 boxes use a cloud based guide and have proven to be extremely signal sensitive. High quality signals both incoming and outgoing are very important to reliable X1 service.