Community Forum

X1 audio dropouts on 4K XG1v4-A cable box

Frequent Visitor

X1 audio dropouts on 4K XG1v4-A cable box

I have been experiencing audio dropout issues with the new X1 4K cable box (XG1v4-A). This has been plaguing me since I got the new 4K box in December. Audio seems to cut out periodically or gets jittery/robotic when watching TV or utilizing On Demand and Streaming App services (Netflix, Amazon Prime, YouTube). This is sometimes alleviated temporarily by changing the channel, stopping and restarting the on demand or streaming show. Most of the time, a reboot of the cable box resolves the issue for a little while, but it eventually comes back and is so annoying. I am running a brand new Samsung UHD TV with a Sony 4K home theater receiver. HDMI is connected from cable box to TV HDMI input and then I utilize the HDMI ARC to the receiver. This occurred with my previous UHD 4K TV as well. (Replaced in January). I have tried the following- - Replaced all HDMI cables with brand new ones. - Changed TV HDMI input to 3 other ones with no change. - Changed Coax cable from wall to cable box. - Had signal strength checked and refreshed. Signal is strong. - Changed from HDMI ARC to optical cable between TV and home theater receiver. - Verified that audio issue is not seen with Blu-ray Player, PS4, Xbox, and Smart TV streaming apps. Only the cable box. - Verified that HDMI CEC (Anynet+) is enabled on all devices and also toggled it off and on after rebooting the cable box. - Got a new 4K cable box with the same result. - Changed cable box audio setting from Auto to Expert with no change. Stereo works fine, but I lose the 5.1 surround sound, which defeats the purpose. - Connected cable box directly to TV via HDMI and used TV speakers. Audio issue still occurred. I am at my wits end here and there is definitely an issue with the 5.1 sound with this 4K cable box. I am hesitant to go replace the box again. I need Comcast/Xfinity to get to the bottom of this audio issue as I am paying good money to have spotty audio when viewing content . Is there another 4K box or a fix for this issue? Please investigate as I am strongly considering other carriers for my TV and Internet service.
Gold Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box

How is the audio getting to the home theater receiver? TOSLINK cable? Replace the cable. TOSLINK cables are notoriously fragile.

Is your receiver indicating that it is receiving 5.1 audio? There might be another setting in the TV to check.

Also, check the audio settings in your TV and turn off any and all "sound enhancement" features. They can cause an over processing of the audio signals.

In regards to audio, X1 boxes are very simple. They offer stereo or 5.1 Dolby Digital. That's it. I have three X1 boxes currently connected to three different audio systems and I cannot duplicate your issues.
Gold Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box

Whoops. Just noticed you are using ARC to feed the receiver audio.

I am not a big fan of ARC and I don't use it. The consumer electronics industry has yet to fully embrace and support ARC.
Expert

Re: X1 audio dropouts on 4K XG1v4-A cable box

I've seen other threads where this was caused on the DVR only when another companion set top box in the home was using the DVR's internal modem. Do you have smaller set top boxes too? if so is there on that is larger than the others (model on the box XG2)? the XG2 has its own tuners and cable modem that the other smaller set top boxes can use instead of the DVR's.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

Yes, receiver is getting 5.1 audio. I was using ARC to the receiver, but as I mentioned in my post, the current setup is HDMI to TV and then optical/TOSLink cable to receiver. The optical cable is brand new. The HDMI cables are brand new. There are no sound enhancements turned on within the TV. The problem here and what I have seen with numerous other posts on this topic, is that the 5.1 audio coming out of the 4K box is having an issue. I do have another cable box, but it is one of those small boxes that does not have a DVR in it. It is totally random dropouts on audio and there is no pattern or time cadence as to when it occurs. I did also go into the service menu by using the button sequence. (Hold xfinity button for 10 seconds, press down twice, and then press the number 2. This opens up the diagnostic menu. There is no specific audio data or test, but everything looks good coming into the STB. The problem is the output from HDMI. There is no optical out on this box, so the only output to test for audio is HDMI. As I mentioned before, the straight HDMI from box to TV using the TV speakers and cutting out the receiver, still exhibits the audio dropout. I tested this with another 4K TV using the straight box to TV HDMI connection and using the TV speakers and had the same result of audio dropping out. This is my second 4K cable box that has this issue. I really need Comcast to investigate this. The signal is strong to my box, but this doesn't account for potential drops that could occur sporadically coming in from the street/demarcation point that could impact the audio stream. I have seen no issues with video at all.
Gold Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box

How do you know you signal level is strong? Did you check it when in the diagnostic screen?

X1 boxes use a cloud based guide and proven to be extremely signal sensitive. To issues you are describing could be deficient signals.
Frequent Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

Technician measured the signal. There is also a menu selection on the X1 boxes under Comcast labs with a signal meter. The diagnostics also showed a strong signal and audio/video stream.
Gold Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box

You might need another tech for two reasons:

 

1. Not all techs know what too look for. Just last Saturday I had X1 installed at our new house. The suncontractor install tech proclaimed my signals as "just fine" but they are not. The upstream levels are too high which would eventually lead to freezing and lock ups. I have another tech coming today to hopefully do it right.

2. The signal meter in Comcast Labs is over simplified and often inaccurate. That meter can read fine yet you can have severe signal issues, especially on the upstream. That meter only tests a small handful of X1 signals and should NOT be relied on.

I would get another tech out.




@gev75 wrote:
Technician measured the signal. There is also a menu selection on the X1 boxes under Comcast labs with a signal meter. The diagnostics also showed a strong signal and audio/video stream.

 

Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

Hello @gev75, thanks for reaching out to our forums about this audio concern on the 4K cable box! I would be more than happy to further look into this as well as get another tech out if needed. Can you please send me a private message including the full name as it appears on the account and your full name if different? 

 

To send me a Private Message, please click my name “ComcastAmira” and click “send a message". 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: X1 audio dropouts on 4K XG1v4-A cable box

@ComcastAmira 

Same issue here with XG1v4-A box, been going on for a long time, every single recording is pixelated, along with audio out of sync. Also happens on live tv, comcast channels only, internet tv is always fine. Netflix and Amazon fine. I tried clicking on your name, but do not see a send message button. I have refreshed and reset numerous times, never changes a thing. Was really bad for GoT this past episode, but then it played fine live on Monday. Thanks for any advise,

Silver Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box


@HopFarmr wrote:

@ComcastAmira 

Same issue here with XG1v4-A box, been going on for a long time, every single recording is pixelated, along with audio out of sync. Also happens on live tv, comcast channels only, internet tv is always fine. Netflix and Amazon fine. I tried clicking on your name, but do not see a send message button. I have refreshed and reset numerous times, never changes a thing. Was really bad for GoT this past episode, but then it played fine live on Monday. Thanks for any advise,


It may be hard to see; it is on the right side of the profile:

Send a message-3.jpb.jpg

 

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

Hello @HopFarmr, thanks for reaching out to our Forums! I'm sorry to hear that you are experiencing this audio issue on your 4k box as well. I also watch GOT and I can definitely understand how frustrating that would be when trying to watch. I would be more than happy to further assist you with this. Yes, if you could please send me a private message including the full name as it appears on the account and your full name if different? 

 

To send me a Private Message, please click my name “ComcastAmira” and click “send a message". 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Gold Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box

Recently I have noticed that ALL 3 X1 of my boxes I have are doing this... not just my XG1V4. But they demonstrate the issue slightly differently.

HOWEVER, the audio dropout is often accompanied be a slight pixelation or blip in the picture.

I have a history of blaming local signal issues (in home) for problems like this. I am almost always right. Many people are quick to blame Comcast software. In the case of this issue I do think it is a network issue outside of the house. I think the problem is too intermittent and unpredictable to be within my house.

If it continues I will invite a Comcast tech out to our house.

Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

Hello @RickGr4, thanks for reaching out and providing us this feedback. We appreciate it! Yes, please do reach out to us if you need any further assistance with this or any other issues or concerns. Thank you and we appreciate you being the best part of Comcast 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

I’m having the same issues. Did you get it fixed?

Frequent Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

No, they are opening a case with national tech support. Clearly an audio driver issue. Lots of reports of the problem, but no movement on a fix.
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

We just got a new 4K tv and Dolby Atmos sound bar and I’m so disappointed in the audio out of the xfinity 4K box. I hope they do something quickly! Thank you for responding.

Expert

Re: X1 audio dropouts on 4K XG1v4-A cable box


@Kwilt wrote:

We just got a new 4K tv and Dolby Atmos sound bar and I’m so disappointed in the audio out of the xfinity 4K box. I hope they do something quickly! Thank you for responding.


use voice remote 'about'. what is the rest of the line to the right of 'STB version...'?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

AX014AN_3.3p14s1_PROD_sey

Expert

Re: X1 audio dropouts on 4K XG1v4-A cable box


@Kwilt wrote:

AX014AN_3.3p14s1_PROD_sey


same version i have right now.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

Hi @Kwilt

 

Thank you for using the Xfinity Forum. We are in the process of finding a solution for this now. To ensure your audio issues are resolved as well, can you please send me a private message with your first and last name so I can link your account to the national investigation that is open? To send a private message click on my name "ComcastChe", then click send a message. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

Same problem here - intermittent audio drops since installing the xg1v4 box. Frustrating.

Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

Same problem here - intermittent audio drops since installing the xg1v4 box. Frustrating.

tmirro, shoot me a PM for help with your full name please. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: X1 audio dropouts on 4K XG1v4-A cable box

I’ve had this problem ever since I got the 4K box. Had no problems with my prior DVR box. Any help is appreciated-I might have to go back to the non 4K box which would be something I don’t want to do or maybe switch to Direct TV
Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

@StuartG1

 

Thank you for using the Xfinity Forum. I can help. Please send me a private message with your first and last name. Click on my name "ComcastChe", then click send a message. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: X1 audio dropouts on 4K XG1v4-A cable box

My X1 also loses audio for periods of time. And then will return. How do I get added to the national resolution thread? 

Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

I can help @Kkorsgard. Just send me a private message with your first and last name and I can assist you from there. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: X1 audio dropouts on 4K XG1v4-A cable box

I’m having the same issue.
Official Employee

Re: X1 audio dropouts on 4K XG1v4-A cable box

I’m having the same issue.

B00merang, Hi, thanks for posting. Are you also using 3rd party sound equipment? Are you seeing drops in stereo? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

I have been having the same problem.  Audio cuts out  for a second every once and a while.  Worse about once or twice a day i cuts out completely and stays that way..  I  switch input to Netflix via TV app and other apps sound is fine. Sound comes back after turning TV off for a while. HDMI from X1 to Samsung QLED 49”   Optical to sound bar.  No Sound out from TV speakers either when this happens.  Very frustrating. Will happen in the middle of a show.  This began happening about 4 weeks ago. Weve had tv and X1 box since November with no problems untik recently

Expert

Re: X1 audio dropouts on 4K XG1v4-A cable box


@Asellitto wrote:

I have been having the same problem.  Audio cuts out  for a second every once and a while.  Worse about once or twice a day i cuts out completely and stays that way..  I  switch input to Netflix via TV app and other apps sound is fine. Sound comes back after turning TV off for a while. HDMI from X1 to Samsung QLED 49”   Optical to sound bar.  No Sound out from TV speakers either when this happens.  Very frustrating. Will happen in the middle of a show.  This began happening about 4 weeks ago. Weve had tv and X1 box since November with no problems untik recently


does your soundbar offer HDMI inputs? If so try in to soundbar out to TV and remove optical cable (very old technology that is outdated). alternatively, remove optical and run HDMI from the HDMI ARC connector to the soundbar. have you tried to test audio when issue is happening by turning down soundbar and turning up TV volume to see if same issue?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

Its not the soundbar connection. The TV speaker doesn’t work either. And the soundbar works fine with Netflix and all other tv apps. The  only cure is to turn the TV off for a few minutes.  It worked fine for months.   Suddenly in March or April complaints began. Was there a modem upgrade performed by Xfinity?  

Regular Visitor

Re: X1 audio dropouts on 4K XG1v4-A cable box

Does anyone know if the HDMI input audio format is Bitstream or PCM.  My tv has both options. Its set at Bitstream. Will changing that setting make any difference.

Silver Problem Solver

Re: X1 audio dropouts on 4K XG1v4-A cable box


@Asellitto wrote:

Does anyone know if the HDMI input audio format is Bitstream or PCM.  My tv has both options. Its set at Bitstream. Will changing that setting make any difference.


No clue; it won't hurt to try it; you can always change it back.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!