Xfinity plant
Xfinity globe
Community Forum

X1 Box Won't Turn On

New Poster

X1 Box Won't Turn On

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!

Regular Contributor

Re: X1 Box Won't Turn On

Has it ever worked?  If so, the box or TV may have a problem.  If you are just starting out, I would guess you don't have the cabling correct and/or the tv input is not set correctly. If the blue light is on, the box is on.


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!


 

New Poster

Re: X1 Box Won't Turn On

No, I've had it installed for a few months now and it has worked fine. 

Expert

Re: X1 Box Won't Turn On


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!


Sounds like you need to take it to a Comcast Store and exchange it for a new box.

Official Employee

Re: X1 Box Won't Turn On


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!

 

____________\

 

Are you on the proper input on your TV?

 Update, it's showing offline, check your cable connections and if it continues either have a tech out to check your connections and swap your box or swap your box at your local service center. Your modem is online and signal looks good.

New Poster

Re: X1 Box Won't Turn On

Thanks, it is on the proper input and still not working.

Valued Contributor

Re: X1 Box Won't Turn On

Mario - 

 

I have the same problem and it has to do with COMCAST updating the X1 box from time to time. I had month it worked - NO CHANGES IN BETWEEN - then it stopped working - then it worked again and right now It's not. I checked the Sofware revision on my box the whole time and everytime it stopped working they send a new update to my box ! Yeahhhh 

 

Ok try this turn every thing on - if the blue light is on your box - turn it manually off by pushing it once - count to 5 and push it once - it takes some time to lid up again .. that's HOW i get my box to work right now ! I just had to do this again 5 min ago :-)  Software GLITCH !