Xfinity plant
Community Forum
Xfinity globe

Wireless x1 box freezes CONSTANTLY

New Poster

Wireless x1 box freezes CONSTANTLY

Hello, We have had xfinity for about a year and have constantly been having problems with the one tv that we had a wireless cable box installed on. The TV literally freezes 4-5 times per day and something freezes every few minutes for hours on end. Even after a full system reboot (wireless router, core x1 box that is connected via coax and wireless box that is connected to tv) the problem often persists. We even updated to the latest xfi router hoping the increase in speed would help but there has been no improvement. Does anyone have a fix? Ive seen multiple articles about this online and no one has a fix. At this point i am ready to drop the system altogether.
Expert

Re: Wireless x1 box freezes CONSTANTLY


@vjbella wrote:
Hello, We have had xfinity for about a year and have constantly been having problems with the one tv that we had a wireless cable box installed on. The TV literally freezes 4-5 times per day and something freezes every few minutes for hours on end. Even after a full system reboot (wireless router, core x1 box that is connected via coax and wireless box that is connected to tv) the problem often persists. We even updated to the latest xfi router hoping the increase in speed would help but there has been no improvement. Does anyone have a fix? Ive seen multiple articles about this online and no one has a fix. At this point i am ready to drop the system altogether.

as a customer, I would switch to ethernet (across floor) to do a test to rule out wifi issues. If it works well on ethernet then you can deduce it is a wifi strength or signal to noise issue (brick walls, tile walls block wifi). 

Official Employee

Re: Wireless x1 box freezes CONSTANTLY


@vjbella wrote:
Hello, We have had xfinity for about a year and have constantly been having problems with the one tv that we had a wireless cable box installed on. The TV literally freezes 4-5 times per day and something freezes every few minutes for hours on end. Even after a full system reboot (wireless router, core x1 box that is connected via coax and wireless box that is connected to tv) the problem often persists. We even updated to the latest xfi router hoping the increase in speed would help but there has been no improvement. Does anyone have a fix? Ive seen multiple articles about this online and no one has a fix. At this point i am ready to drop the system altogether.

Internet speed has nothing to do with it. It's your wifi connevtivity. Try changing channels that your WiFi is broadcasting on or you may have to find a different way to get it connected or get cable to that area and use a different device.