Community Forum

Welcome screen frozen with Xfi wireless box

New Poster

Welcome screen frozen with Xfi wireless box

Hello. I just got xfinity service a few weeks ago. My main room tv, wireless xfi box, has a light on that is continuously flashing. Also, the "Welcome.." screen is frozen on the tv and has been for a few hours now. I have other tv's that work perfectly fine, along with my Wifi. The remote won't let me turn any channel or anything, just turn off the tv. I have unplugged everything, restarted all the systems with no luck. Any help would be appreciated.
Expert

Re: Welcome screen frozen with Xfi wireless box


@b27sls0 wrote:
Hello. I just got xfinity service a few weeks ago. My main room tv, wireless xfi box, has a light on that is continuously flashing. Also, the "Welcome.." screen is frozen on the tv and has been for a few hours now. I have other tv's that work perfectly fine, along with my Wifi. The remote won't let me turn any channel or anything, just turn off the tv. I have unplugged everything, restarted all the systems with no luck. Any help would be appreciated.

on your modem/gateway locate the MoCA LED, is it illuminated?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Welcome screen frozen with Xfi wireless box

i'm experiencing the same problem with the screen only saying "welcome, etc" and not doing anything. the blue light is not on the box. we've taken the plugs out and back in, no change. what do i do next?