Community Forum

Trouble pairing XR11 with Sony Bravia TV

New Poster

Trouble pairing XR11 with Sony Bravia TV

Just got upgraded to the X1 DVR and XR11 voice control remote. The remote works with the DVR fine, it just will not pair with any of the provided codes with the TV itself for volume, power, etc. I have a Sony Bravia KDL 52V4100. Every code flashes red, then green, instead of the double green it says it will do when paired. Am I missing something?

Official Employee

Re: Trouble pairing XR11 with Sony Bravia TV

Just got upgraded to the X1 DVR and XR11 voice control remote. The remote works with the DVR fine, it just will not pair with any of the provided codes with the TV itself for volume, power, etc. I have a Sony Bravia KDL 52V4100. Every code flashes red, then green, instead of the double green it says it will do when paired. Am I missing something?
_______________

Have you paired the remote to the dvr? And follow the prompts for additional codes, there's 12-14 codes for Sony
New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

Yes, I entered the 3 digit code and paired it fine to the DVR. On the next screen when it asks me to pair it to the TV, I've tried all of the codes on there a few times each with no success. A few of the codes give me the double green flash, but still doesn't control the volume after that.

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I've solved the problem using the manual code search here:

http://forums.xfinity.com/t5/X1/XR5-and-XR11-quot-Voice-Remote-quot-Code-Lists/td-p/2550616

 

 

Official Employee

Re: Trouble pairing XR11 with Sony Bravia TV

Great, that was the next suggestion.
Contributor

Re: Trouble pairing XR11 with Sony Bravia TV

I can't get the xr11 to work with any TV in my house.  Got 4 new motes yesterday and only the xr11 silver voice remote can not be programmed.  I know the codes that work with the other new remotes so it does not seem to be a code issue.  I think there is a bug in the setup.

 

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV


bobs99 wrote:

I can't get the xr11 to work with any TV in my house.  Got 4 new motes yesterday and only the xr11 silver voice remote can not be programmed.  I know the codes that work with the other new remotes so it does not seem to be a code issue.  I think there is a bug in the setup.

 


The Xr11 remote is NOT Silver in color....

Contributor

Re: Trouble pairing XR11 with Sony Bravia TV

Perhaps not yours.  On the back lower left in a faint print mine said xr11.  The black ones are xr5.  I will compromise and call it grey if that makes you happy.  Too add some more color, I just tried a 2nd xr11 "grey" remote.  Still no good.  Based on the paperwork I received with this it has a list of 8 tv brands it works with so it must not accept all the codes as the other remotes.  So I will place this remote in a drawer for now, and revisit "voice control" sometime in the future.

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV


bobs99 wrote:

Perhaps not yours.  On the back lower left in a faint print mine said xr11.  The black ones are xr5.  I will compromise and call it grey if that makes you happy.  Too add some more color, I just tried a 2nd xr11 "grey" remote.  Still no good.  Based on the paperwork I received with this it has a list of 8 tv brands it works with so it must not accept all the codes as the other remotes.  So I will place this remote in a drawer for now, and revisit "voice control" sometime in the future.


Did you try here?  http://customer.xfinity.com/remotes/

It includes the Xr11 Voice Remote and lots of codes for each manufacturer

Contributor

Re: Trouble pairing XR11 with Sony Bravia TV

Yes-  These seem to be the same codes as for the other x1 remotes I just got.  2 of my TV's are insignias and the 11780 code works for them the other non-voice remotes.  The voice remote with that code or other Insignia codes does not work on the same TV's.  I also tried on a OLevia TV which has a code listed that works with new non-voice remotes but would not work for this voice remote. 

 

There is something wrong with the setup function in the voice remote.  The directions and codes look the same but it does not work(at least in 2 of 2 remote tests on 2 TV's) to program for a TV.

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I, too, am having a problem getting my XR11 remote to pair with my Sony Bravia TV.  I enter code "11685," get the two flashes of green on the remote and ... nothing.  Also, I can change the channel on the X1 cable box, but I cannot turn the box off.  I've also tried to set up the voice function, but no luck.  Very frustrating...

Silver Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV


TwinTulips wrote:

I, too, am having a problem getting my XR11 remote to pair with my Sony Bravia TV.  I enter code "11685," get the two flashes of green on the remote and ... nothing.  Also, I can change the channel on the X1 cable box, but I cannot turn the box off.  I've also tried to set up the voice function, but no luck.  Very frustrating...


http://customer.xfinity.com/remotes/

 

11685 is only one code, there are still plenty others that may work.

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV


TwinTulips wrote:

I, too, am having a problem getting my XR11 remote to pair with my Sony Bravia TV.  I enter code "11685," get the two flashes of green on the remote and ... nothing.  Also, I can change the channel on the X1 cable box, but I cannot turn the box off.  I've also tried to set up the voice function, but no luck.  Very frustrating...


As John stated, there are MANY codes for a SONY brand TV...  use the remote codes listed in your HELP settings of the X1 system...there seem to be more listed there than the online support...   Additinally, the boxes are designed to stay on 24 hours/day....   you can either manually push the power button, or set up the Power Save feature within Device Settings>>>Power Preferences in your settings.

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I just got the XR11 remote and can't get it to pair with my Sony TV either.  The non-voice remote paired fine.  I've tried all the codes, any other suggestions?

Expert

Re: Trouble pairing XR11 with Sony Bravia TV


geek46 wrote: <snip>
ray your signature line must have a formatting 'error' as last line is only 1/2 shown (maybe too long?). here is what we see:
signature1.jpg

I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I had the same problem with pairing the xr11 remote to a Sony Bravia.  When trying to enter the different codes provided, none worked.  I called customer support - no help.  I tried this fix that was posted and it worked like a charm and was much easier than entering and trying all the different codes.

The frustrating part is that customer support seemed to know nothing about this problem or the solution! 

See Below:


bbgn wrote:

I've solved the problem using the manual code search here:

http://forums.xfinity.com/t5/X1/XR5-and-XR11-quot-Voice-Remote-quot-Code-Lists/td-p/2550616

 

 


 

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

Had the same problem with the Sony Bravia, that worked perfectly

Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV

I have the same issue but my remote flashes double green using 3 different codes yet none of them allow the remote to control the tv volume.

Silver Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV


Hughey101 wrote:

I have the same issue but my remote flashes double green using 3 different codes yet none of them allow the remote to control the tv volume.


Did you try the code search?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I had this problem with my Sony Bravia TV and I finally figured out it was because I had a DVD player hooked up to it.  You have to disconnect anything else connected to your TV first.  Once I disconnected the DVD player, I was able to program the remote by pressing setup, entering 991, pressing channel up until TV turned off, pressing setup and then pressing the TV button on upper left of remote.  This successfully programmed my remote.  After that, I reconnected DVD player and everything worked fine.  I hope this helps someone.

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

Thanks for the input Sherry but your DVD player had nothing to do with this. It was a coincidence.
Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV

Thanks Sherry! Your clear instructions solved the problem for me; Comcast phone support was totally useless...

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

I will say this again for the benefit of anyone that may read this in the future.

Successfully programming an X1 remote to control a TV set has nothing to do with the TV being on or off. It has nothing to with the TV being plugged in or not. It has nothing to do with any extra devices that may be plugged in to the TV set.

I am aware that Comcast has a "help video" that makes it appear the TV is involved in the programming process but in reality the process is passive and not interactive with the TV.


The instructions posted here are current and accurate: http://customer.xfinity.com/help-and-support/cable-tv/remote-program-the-xr2-or-xr5-to-control-a-tv/

Please note these instructions do not say anything about any additional devices connected to the TV.  


ZaphodInWA wrote:

Thanks Sherry! Your clear instructions solved the problem for me; Comcast phone support was totally useless...






Silver Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

Another possibility is to use the online procedure:

 

http://customer.xfinity.com/help-and-support/cable-tv/x1-help-find-and-view-help-videos/

 

I set up all my remotes using this procedure.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV

I guess I should have been more specific about my reason for thanking Sherry126. It was for the following simple, clear  guidance, which worked for me the first time: "program the remote by pressing setup, entering 991, pressing channel up until TV turned off, pressing setup and then pressing the TV button on upper left of remote". That's all it took.

 

With all due respect to RickGr4 and RobertWy, if Comcast's on-line documentation were even close to being complete and useful then I'd have found the answer before scouring to this forum. Apparently (this from the Comcast help agent I called) the new XR11 remote does not support my Sony Bravia TV, nor does it support my VIZIO sound bar. Both of these claims are a little amazing considering how common both devices are from major chains like Best Buy.

 

In summary, guidance for configuring systems as complex as the X1 platform must not only exist, it must also be possible to find and follow them successfully.

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

Which codes did you try for your Vizio and where did you get them from???

http://forums.xfinity.com/t5/X1/XR5-and-XR11-quot-Voice-Remote-quot-Code-Lists/m-p/2550616#M73148


ZaphodInWA wrote:

I guess I should have been more specific about my reason for thanking Sherry126. It was for the following simple, clear  guidance, which worked for me the first time: "program the remote by pressing setup, entering 991, pressing channel up until TV turned off, pressing setup and then pressing the TV button on upper left of remote". That's all it took.

 

With all due respect to RickGr4 and RobertWy, if Comcast's on-line documentation were even close to being complete and useful then I'd have found the answer before scouring to this forum. Apparently (this from the Comcast help agent I called) the new XR11 remote does not support my Sony Bravia TV, nor does it support my VIZIO sound bar. Both of these claims are a little amazing considering how common both devices are from major chains like Best Buy.

 

In summary, guidance for configuring systems as complex as the X1 platform must not only exist, it must also be possible to find and follow them successfully.


 

Silver Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

My link worked for all four of my X1 and a/v receivers.

 

And it is part of the X1 Guide Help, which is accessible from your TV.

 

I can't imagine it being more accessible.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV


RickGr4 wrote:

Which codes did you try for your Vizio and where did you get them from???

 


The online pairing setup for audio devices listed two codes for a VIZIO sound bar; I tried both (twice, actually) and neither worked. In the end I worked around this problem by training the soundbar to recognize the XR11 remote's IR codes - rather than the other way around. All I needed were Vol+, Vol- and Mute, and this did it for me; one less remote cluttering my coffee table.  Smiley Happy

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

Glad you found a solution but "training" the soundbar has been discussed here... That is how SONOS does it.

So I take it you tried 31937 and 31975? Which Sony codes did you try? How do you know you tried ALL of the available Sony codes? Many others have solved this issue with the 991 process. I would be asking myself what I am not doing properly if many others found a solution...


ZaphodInWA wrote:

The online pairing setup for audio devices listed two codes for the VIZIO sound bar; I tried both (twice, actually) and neither worked. In the end I worked around this problem by training the soundbar to recognize the XR11 remote's IR codes - rather than the other way around.







Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV


RobertWy wrote:

My link worked for all four of my X1 and a/v receivers.

 

And it is part of the X1 Guide Help, which is accessible from your TV.

 

I can't imagine it being more accessible.


So what's your point exactly? I followed the setup directions exactly (tried all 14 or so Sony TV codes listed one after the other) and none worked for me. Repeat: None of the codes provided worked!

 

See if this helps your 'imagination':

 

  • Many frustrated customers have posted about similar problems with the XR11 on this and other forums, so I'm obviously not alone in experiencing it.
  • Repeating my earlier statement, the 800-XFINITY help agent told me when I finally gave up and called: "We're sorry, neither the Sony TV nor the VIZIO sound bar is supported. Maybe you should call VIZIO..."

I find your response arrogant and unhelpful.

 

Frequent Visitor

Re: Trouble pairing XR11 with Sony Bravia TV


RickGr4 wrote:

Glad you found a solution but "training" the soundbar has been discussed here... That is how SONOS does it.

So I take it you tried 31937 and 31975? Which Sony codes did you try? How do you know you tried ALL of the available Sony codes? Many others have solved this issue with the 991 process. I would be asking myself what I am not doing properly if many others found a solution...


 

I don't recall which codes (displayed to me by the pairing wizard) I tried for the VIZIO; just that there were two of them and neither worked.
As noted in a previous post the setup wizard led me through some 14 different Sony codes and none of them worked - even though my previous XFINITY set-top box (Motorola RNG200N) had no problem with my Bravia model.

Actually what I ended up asking myself was whether XFINITY did any field testing / QA at all on this new model before they shipped it. In the end of course I did discover what AFAIK is the only feasible workaround to the problem; if I hadn't then I'd be packing the unit up for return.

Gold Problem Solver

Re: Trouble pairing XR11 with Sony Bravia TV

Like I said in my last post, others have figured out the Sony TV remote code issue. There are many success stories out there. Obviously there is at least one remote code for Sony TVs that works but Comcast has not published. Aren't you curious what others have figured out something that you haven't?

As I said earlier, the "pairing wizard" is not the final answer. It appears the 991 manual code search process is.

Look, Comcast seriously cut corners with X1. It is not a deluxe product. It is not a product designed for enthusiasts. X1 is all about cost cutting at every turn. You need to play their game and adapt. Otherwise go back to legacy boxes or find another provider. Comcast isn't going to change X1 to suit one user.

The longer you hang out in this forum the sooner you will understand...

Oh by the way, Comcast budgets to lose hundreds if not thousands of customers every single day. It is called "churn". Threatening to return things or leave Comcast is pointless. They have heard it all before... many times.

 


ZaphodInWA wrote:

RickGr4 wrote:

Glad you found a solution but "training" the soundbar has been discussed here... That is how SONOS does it.

So I take it you tried 31937 and 31975? Which Sony codes did you try? How do you know you tried ALL of the available Sony codes? Many others have solved this issue with the 991 process. I would be asking myself what I am not doing properly if many others found a solution...


 

I don't recall which codes (displayed to me by the pairing wizard) I tried for the VIZIO; just that there were two of them and neither worked.
As noted in a previous post the setup wizard led me through some 14 different Sony codes and none of them worked - even though my previous XFINITY set-top box (Motorola RNG200N) had no problem with my Bravia model.

Actually what I ended up asking myself was whether XFINITY did any field testing / QA at all on this new model before they shipped it. In the end of course I did discover what AFAIK is the only feasible workaround to the problem; if I hadn't then I'd be packing the unit up for return.





New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

Ok, I just came across this topic and read it with great interest.  The short version of my story is that yes, I too had trouble getting the XR11 to control the Sony Bravia TV power and the receiver volume.  Only after trying the "manual" mode (setup 991 up channel until TV turns off method) did everything started to work.  I am convinced that the XR11 with the voice control cannot be programmed via entering the 5 digit code if you have a Sony Bravia TV.

 

Now the long version:  My old comcast DVR finally crashed after 10 years.  I went down to the brick and mortar comcast store and came home with a brand new DVR and another set-top box on the X1 platform.  I was able to set both of them up relatively easily.  The DVR version came with the voice control remote XR11 and the non DVR box came with the remote XR5.  I was able to program the XR5 to control my old no name defunct Olevia TV upstairs in the guest room.  Then came the main entertainment room with the Sony Bravia TV.  I did the whole thing with pairing the dvr with the remote.  Then I tried to enter the 5 digit code for the Sony TV.  The funny thing was that I noticed that after entering 4 of the 5 digits, the green/red light flashed red.  The instructions clearly indicates that the green light should flash twice after the 5 digit code is entered.  That clearly did not happen.  I went through about 5 codes like this before giving up and exiting.  Everything worked, the channels, the xfinity button, the voice control, all except the TV power and volume.  

 

After flipping through some channels, I decided to try again.  Held down setup for 3 seconds, waited the LED to turn green and then proceeded to enter another 5 digits.  That's when it became clear that something was terribly wrong with the whole programming thing.  What happened was that after 3 of the 5 digits were entered, the remote flashed red and then treated the last two digits as if I were trying to select the channel.  In other words, the remote did not even allow me to enter the 5 digits.  This happened when I tried to program the receiver too.  I finally gave up and called comcast service and spoke to a nice lady who tried to walk through the process with me.  I knew it wasn't going to work since following the instructions wasn't the problem to begin with.  When I told that the LED was flashing red only after 3 digits, she agreed with me that the problem was probably the remote and she promised to ship me a new remote.  I got off the phone and decided to try to program the XR5 remote for the other box with the sony code "10000".  Everything went smooth and all the lights flashed as described in the instruction.  And most importantly, that XR5 remote was able to turn the Sony TV on and off.   So I was further convinced that it was my XR11 remote that was the problem.

 

Fast forward 3 days.  I get home from work and see a huge box from Comcast on my porch.  Instead of sending a single remote, Comcast sent two additional receivers that I didn't need.  With each receiver, there were a XR11 remote so I thought that I would return the receivers but swap out one of the remotes with my defective remote.  I tried to program one of two newly received XR11 remotes and the same issue popped up again in the same exact fashion.  I tried the last XR11 remote (I am on my third XR11 remote by now) and the same thing again.  At this point, I came to the conclusion that there is no way I could be that unlucky and get three defective XR11 remotes.  I thought there had to be some issue and googled.  That's how I came to this thread and by learning about the manual method, I was able to program the remotes correctly.  Ironically after all that trouble, the Sony TV was programmed with the first press of the Channel up button.  My Yamaha receiver took about 30 presses of the Channel up button before it too was recognized.  Everything is finally working as intended.

 

What I found interesting was that once the remote failed to work with the Sony code, it seemed like you couldn't program it to any other brand either because like I said, you were never able to even enter the full 5 digits.  I tried entering the code for the Olevia TV just to see if that would work and I couldn't even enter the 5 digits without the remote flashing red after the 3 digits and then treating the last two digits as a channel selection. 

 

I even tried unpairing the remote (setup for 3 seconds, then 9-8-3) and restarting the pairing process.  While the remote paired and everything else worked, it just would not let me enter a 5 digit code.  A part of me would like to know what's really going on becasue I can't imagine that this happens to everyone but the manual method worked so I guess I should consider myself lucky.   

 

 

    

 

 

Expert

Re: Trouble pairing XR11 with Sony Bravia TV


fivestar73 wrote:

Ok, I just came across this topic and read it with great interest.  The short version of my story is that yes, I too had trouble getting the XR11 to control the Sony Bravia TV power and the receiver volume.  Only after trying the "manual" mode (setup 991 up channel until TV turns off method) did everything started to work.  I am convinced that the XR11 with the voice control cannot be programmed via entering the 5 digit code if you have a Sony Bravia TV. 

<snip>

 

 

 


you said you used the scan method and now can control your sony.  You can determine the code that works and please post the code here for others to find and use. 

 

with the remote in hand press setup until LED changes to green. press 990. press 1 and count the LED flashes, press 2 and cound the flashes, continue to 5. if flashes 'none' that is zero, flashes 1, is '1', etc. To verify do it again and verify the numbers you wrote down have the correct number of flashes. write down the 'code' and now you can input that code directly.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

Rusty, I am not sure if that method will work with Sony.  For this topic, it's not a matter of finding the right code in my opinion.  As I verified with the XR5 remote, code 10000 should work fine with Sony.  

 

For whatever reason, the XR11 remote gets into a "funky" mode where it won't allow you to enter the 5 digit code after the voice control has been activated through the three digit pairing.  The only thing I can't verify is if this is exclusive to Sony TV owners only or if other brands are affected.  There are other posts in the thread that describes the manual method in more detail but I believe that method works because it doesn't rely on entering codes. 

 

The thing that puzzles me is that the brand of TV shouldn't really affect how the remote's programming function works.  I myself would have a hard time believing this since the programming of the remote should be indepedent of TV brand.  (That is either you put in the right code or you don't) But based on several anecdotes on this thread as well as many other threads, something about Sony TV triggers a bug in the XR11 remote's programming routine after the voice control has been activated.  That's the best I can describe this problem. 

 

By the way, I also unpaired the remote, then tried to program the TV code BEFORE pairing the remote but in that instance, the remote just simply refused to recognize my attempts at programming.

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I had your problem with my brivia and used this link https://customer.xfinity.com/remotes/

the second code on the list for Sony worked. Code 10810

hope this helps.

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

Had the same problem. Use code 10810

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

The 991 trick worked great for me. I tried every code listed and my Bravia wouldn't pair. Thank you ZaphodinWA!!!

New Poster

Re: Trouble pairing XR11 with Sony Bravia TV

I tried all the codes listed at xfinity.com/remotes several times with out any luck.  I contacted support which was very helpful, excellent service they advised this was a know issue and to try the following.

 

Push the Setup button until the red light turns green

Enter the code 991

Immediately start pushing on up side of channel change button until the TV turns off, this took about three times on mine.

Push the setup button until the light goes from red to green

Push the TV button, the TV turns on and everything worked.

 

Sounds odd but it worked, had to try it twice.

 

good luck