Community Forum

Sound but no picture

tbg4
New Poster

Sound but no picture

I have sound but no picture on one of my two TVs. I would suspect my HDMI/DVI cable, but it transmits video from my blue ray player.

I have two TVs, and have swapped the boxes, and each box behaves the same on that TV.

My set up is HDMI from X1 box to home theater amplifier (also have a by ray player hooked up to amp.) From there, output is a 50' HDMI-to-DVI cable to my TV. (I have also swapped the amp inputs to make sure it is not a circuit there.)

All was working fine. Plumbers working under the house running a new gas line today in the area of the HDMI / DVI cable. However, I see no cuts, dents, breaks, etc. And it transmits amp out signal from my blue ray just fine.

Rebooting X1 gives me the welcome, then black, then I get audio but no video.

Help!
CCAndrew
Diamond Problem Solver

Re: Sound but no picture

Probably an HDCP issue?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Krystalga
New Poster

Re: Sound but no picture

This is happening to me as well on my living room box starting this morning. My other 4 boxes are working fine. This box is connected to a device that converts HDMI to Component since the tv does not have HDMI. It has worked well the last 4 years until today. I'm also receiving the welcome screen then scrambled video with working audio
Tek
Problem Solver

Re: Sound but no picture

On your remote, Hit the Xfinity Button up arrow, up arrow, #2, and then hit 7 2 0. This will force the box into a lower resolution of 720p. Then go to General Preferences in settings and turn off auto select of best resolution.  

 

Sounds like you are being impacted by the latest software update like me. The box goes to some crazy high resolution and causes no pic. 

 

Using a hdmi extender or adapters causes the xfinity box to incorrectly detect your best possible resolution.  As a result, the hdmi starts sending resolution that your TV cannot process. 

If you have trouble with this call support and have them escalate to tier 2 if they cannot solve it at tier 1. 

 

 


Tek
matt4952
Contributor

Re: Sound but no picture

Could be a picture resolution issue that started after a recent firmware update. There is a resolution some TVs and audio receivers has issues with. (1080p60) Take the Xfinity remote that you use with that X1 box and press “EXIT EXIT EXIT” (3 times fast) then type in on the Keypad “1080” that will change the picture resolution from 1080p60 to 1080i. You can also follow the same steps but instead of typing in “1080” you can try “720”.

tbg4
New Poster

Re: Sound but no picture

This worked to get me picture at 720. My TV is 1080i. There doesn't appear to be an option to select that resolution. Only options are 720 or 1080p60. Did xfinity stop supporting that resolution? So I have to go buy a new TV for $2,500? I would be so unhappy with xfinity. Any ideas on how I can get 1080?
tbg4
New Poster

Re: Sound but no picture

Matt's advice to click "exit exit exit 3x fast and say There's no place like home!" worked to get me picture. Tek's suggestion work to take off auto selection of resolution. Thanks both! But I'm stuck at 720. My TV supports 1080I, but I can't seem to find any way to get that. (Exit exit exit 1080 doesn't work.) Ideas? Am I hosed, and need to drop major bucks on a new 75" TV, merely because xfinity doesn't think me and my 1080I are worthy of support?
Rustyben
Expert

Re: Sound but no picture


@tbg4 wrote:
This worked to get me picture at 720. My TV is 1080i. There doesn't appear to be an option to select that resolution. Only options are 720 or 1080p60. Did xfinity stop supporting that resolution? So I have to go buy a new TV for $2,500? I would be so unhappy with xfinity. Any ideas on how I can get 1080?

please reply with your TV's brand and model number. is it a flat panel TV? a projector? 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Rustyben
Expert

Re: Sound but no picture


@tbg4 wrote:
Matt's advice to click "exit exit exit 3x fast and say There's no place like home!" worked to get me picture. Tek's suggestion work to take off auto selection of resolution. Thanks both! But I'm stuck at 720. My TV supports 1080I, but I can't seem to find any way to get that. (Exit exit exit 1080 doesn't work.) Ideas? Am I hosed, and need to drop major bucks on a new 75" TV, merely because xfinity doesn't think me and my 1080I are worthy of support?

720p is more resolution than 1080i (interlaced) which is poor for motion between fields/frames and is approx equivalent to 500p. you can search google video for presentations showing the difference in the various resolution and progressive vs interlaced.  An example: video link 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
tbg4
New Poster

Re: Sound but no picture

Hi RustyBen,

 

LCD Projection.  Sony XBR Grand Wega (KDF-60XBR950)

Rustyben
Expert

Re: Sound but no picture


@tbg4 wrote:

Hi RustyBen,

 

LCD Projection.  Sony XBR Grand Wega (KDF-60XBR950)


manual https://www.sony.com/electronics/support/res/manuals/4097/40975201M.pdf

page 10

for comcast use component cables or try the DVI at 720p. the 1080i will give less resolution as the TV's panel circuits have to reconvert the image to their native progressive (P) format the LCD does not itself use I (interlaced) video. 

 

There are amazon hdmi to component adapters or get an old xg1v1 that has the component outputs but only 5 tuners and they are buggy about some audio dropouts. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
jboyarsky
Regular Visitor

Re: Sound but no picture

Matt, it worked.  Thank you very much.  You saved us a lot of $.  Why hasn't Comcast/Xfinity notified subscribers to this problem?

sendmarkemail
New Poster

Re: Sound but no picture

Tek, you nailed it! If I didn't shave my head I would have pulled my hair out, thank you for saving me from resorting to ripping out my eyeballs! Your explanation was very detailed, very helpful, and 100% on the money! Your help was greatly, greatly appreciated!
CCAndrew
Diamond Problem Solver

Re: Sound but no picture

Matt, it worked. Thank you very much. You saved us a lot of $. Why hasn't Comcast/Xfinity notified subscribers to this problem?
___________
Do you mean this, posted 2 months ago? And sticky posted at the top of this section of the forums


I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
jboyarsky
Regular Visitor

Re: Sound but no picture

Thought I did post publicly.  What did I do wrong?

beachbrum
New Poster

Re: Sound but no picture

I just tried this on my Samsung both for 720 and 1080 and I could hear the TV pause for a second to change but still no video. Could I have a bigger issue? Or need a new cable box?
Rustyben
Expert

Re: Sound but no picture


@beachbrum wrote:
I just tried this on my Samsung both for 720 and 1080 and I could hear the TV pause for a second to change but still no video. Could I have a bigger issue? Or need a new cable box?

that is usually an HDMI cable issue. did you try removing and reinserting the HDMI cable ends feeling and hearing the click as it locks into place?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
CowboyMM
New Poster

Re: Sound but no picture

Thanks It worked! Comcast needs to train their employees better. I called Comcast and they said it was a bad HDMI Port. They sent a new box. When I hooked up the new box it seemed to work fine at first but then started having the same issues again, especially at night. Was getting ready to waste my time and call Comcast again to send the new box back again and get another. Searched online and found this article. Thanks