Xfinity plant
Xfinity globe
Community Forum

Sound but NO Picture on TV

Frequent Visitor

Sound but NO Picture on TV

Woke up to the comcast box saying BOOT, Unplug the box and rebooted now there is Sound but No Picture. Rebooted and Refreshed over 10 times. Please Help!!

Expert

Re: Sound but NO Picture on TV


@bluebyu66 wrote:

Woke up to the comcast box saying BOOT, Unplug the box and rebooted now there is Sound but No Picture. Rebooted and Refreshed over 10 times. Please Help!!


the sound and video is delivered normally by the HDMI cable. do you have your audio going to the TV via a digital cable? did you check your AVR if you run the cable box through an AVR?

Frequent Visitor

Re: Sound but NO Picture on TV

Thanks for your Reply!! Yes I have HDMI, Don't know what AVR is.. If I use a flashlight you can see the picture.. I am thinking maybe its the TV and not the box..

Expert

Re: Sound but NO Picture on TV


@bluebyu66 wrote:

Thanks for your Reply!! Yes I have HDMI, Don't know what AVR is.. If I use a flashlight you can see the picture.. I am thinking maybe its the TV and not the box..


try a full power unplug from the TV for 3 minutes and plug back in. did it restore the picture? AVR is your receiver (audio) that enables advanced sound decoding.

Frequent Visitor

Re: Sound but NO Picture on TV

Yes, I did that a few times.. Seems funny that its been a few weeks with this new comcast box and it has been nothing but trouble.. Constanly having to reboot and now my TV doesn't work..Thanks for your helpSmiley Happy

Expert

Re: Sound but NO Picture on TV

Sounds like you need a tech visit; call 1800comcast and ask them to check your system.

Which X1 box do you have?

https://www.xfinity.com/support/articles/x1-hub-vs-companion-box

Frequent Visitor

Re: Sound but NO Picture on TV

 If only comcast had a tech worth calling...lol.. No Thanks!!