Community Forum

Re: Having Issues with X1 Platform

New Poster

Re: Having Issues with X1 Platform

Maybe you can help with my problem. Everyday it locks up and freezes. Sometimes pulling the plug resets and its fine for a while and sometimes it just continues. Movies and regular tv just freeze with no error notice and it can take as long as 20 min for it to just start up on its own. I'm sitting here right now waiting for it to reboot and its been going on for two hours. We have two boxes, a main one and a small aux box. Both lock up independent of each other. I've done all the pull the plug drills, the connections are tight and we've had a tech come out and say we have a good signal.<br>Now I'm getting the message:<br>Somethings not quite right and to pull the plug again. I don't think the problem is on our end. I think xfinity has a lousy system that is beyond their capability to fix because since we changed to the x1 platform this is how its always been. Two years of lousy service they can't fix. It always ends up that I have to disconnect both boxes and get new ones which seem to correct the problem for a few months. Getting ready ready to drop them.
Expert

Re: Having Issues with X1 Platform

Hi, I promoted your post to its own thread and have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread from a Comcast Official Employee.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
Official Employee

Re: Having Issues with X1 Platform

Hi, cre8ors - Let me check your connection and cable boxes. Please send me a private message with your full name and a phone or account number so I can pull up your account information. Click on my name ComcastElla, then click Private Message Me. Thank you!