Community Forum

Poor Picture and Static When First ON

Regular Visitor

Poor Picture and Static When First ON

Hi-

I copied this description from an archieved post, as it exactly what is happening but there was no replies / answers.  Any help would be appreciated !

When the cable box and TV are initially turned on, there is loud static and very fuzzy picture.  The remote locks up and doesn't allow the box to be turned off. After 20 to 30 seconds the unit turns off.  Turning it back on then has a normal picture and sound.  I have rebooted the box several times but it does solve the problem.  Any suggestions?

Thanks.

Official Employee

Re: Poor Picture and Static When First ON

Hi kafoka. Thank you for joining the Xfinity Forums and for creating your first post. I can assist with troubleshooting your cable box issue. Please send me a private message and include your full name so I can access your equipment. 

 

To send me a private, message click my name (ComcastJoeTru) to view my profile. Then click "Send a message" and private message me. 
 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Poor Picture and Static When First ON

Hi - 


This is still happening. Daily. 

Official Employee

Re: Poor Picture and Static When First ON

We're sorry to hear that, kafoka. The next step in the troubleshooting your issue will be to send a repair technician out to your home to inspect the wiring setup and possibly replace the box. To continue to this step, please send me a private message with the time you would be available to have our technician visit your home. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Poor Picture and Static When First ON

hI -

 

Any friday all day works - 

Official Employee

Re: Poor Picture and Static When First ON

@kafoka. I have scheduled an appointment for you and have sent you the details via private message. Thank you. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!