Community Forum

Pink screen no sound with HDMI

New Poster

Pink screen no sound with HDMI

Okay so I am new to xfinity, just got my box hooked up with HDMI. I have ax014anc model box, when I start up my tv it’s got a pink overlay and no sound, if I unplug and plug back in HDMI cable everything is fine. I have it hooked up to a Emerson 32” tv. I’ve tried two different HDMI cables, anyone know how to solve issue? Also Cec is turned off
Silver Problem Solver

Re: Pink screen no sound with HDMI

Gear icon - Device settings screen resolution - try different settings


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Regular Visitor

Re: Pink screen no sound with HDMI

I have the same exact problem pink screen no sound I got the new 4K box and it has to do with the HDMI when I unplug it and put it back in it works but I have to do it each time I have an older Emerson TV
Regular Visitor

Re: Pink screen no sound with HDMI

Already tried the different settings and swapped hdmi cord. Tv is 32 inch Emerson maybe 3 or 4 years old
Silver Problem Solver

Re: Pink screen no sound with HDMI


@jazzysez wrote:
Already tried the different settings and swapped hdmi cord. Tv is 32 inch Emerson maybe 3 or 4 years old

If I were you, I would swap the 4k box for a non-4k DVR.  You can't get any 4k content with a non-4k TV.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.