Community Forum

No sound or picture..but I get the menu and guide

Highlighted
New Poster

No sound or picture..but I get the menu and guide

All three tvs are showing the same issue.....there is no sound or picture.  But I can change channels and the channel menu shows the show.  I can hit the guide button and it shows the full guide.  I can change channels through the guide, etc, etc.  It's just that the picture and sound won't show.

 

I've restarted all three set top boxes and have the same issue still with all three.

 

Mark

Expert

Re: No sound or picture..but I get the menu and guide


@marklboucher wrote:

All three tvs are showing the same issue.....there is no sound or picture.  But I can change channels and the channel menu shows the show.  I can hit the guide button and it shows the full guide.  I can change channels through the guide, etc, etc.  It's just that the picture and sound won't show.

 

I've restarted all three set top boxes and have the same issue still with all three.

 

Mark


You need to check all you cables between all your devices inside your home. Start with the first connection coming inside your home: splitters, end cable connections, etc.

 

Seeing the guide only is not unussual. You are seeing the last signal saved when working. After checking all connections, reset each box. If this does not help you may need a technician sent out.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!