Community Forum

No signal message

New Poster

No signal message

I tried to turn on my TV/ Xfinity immediately following accidentally turning off my TV and the message "No Signal" pops up.  

Problem Solver

Re: No signal message

Is your Xfinity TV box powered on as well?

Is your TV input source set to the cable box connection?

Joe V
(not a Comcast employee, just another paying customer)
Official Employee

Re: No signal message

Hi, angelafranke! Could you please provide more details regarding your issue? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: No signal message

We also receive the same message. Either the blue screen or HDMI3 no signal error message. This occurs often so we replaced the main cable box this week. It occurred with the new main cable box today, 11/23/18 at 5:55pm EST. We typically have to press the blue power button on the front of the main xfinity cable box to turn it off and then press it again to turn it back on to get it to reconnect with our VIZIO E55-E1 TV.
Official Employee

Re: No signal message

Hi, Unc4ej. Do you have any of the power saver settings set and do you use the 'all power' button versus the 'TV power' button?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!