Community Forum

No picture on tv when X1 box is turned on

New Poster

No picture on tv when X1 box is turned on

Recently bought a Samsung 4K UHD (UN55NU6900 and when I turn on the TV there is no picture but I hear the sound. It’s not a TV issue because I see the start-up screen. After I re-start the X1 box everything works correctly. I feel there is no reason to restart the box every time I want to watch tv. Using high speed HDMI cable for connection. Are there any specific setting I need to do on the box or tv so this issue doesn’t happen? Do I need a new HDMI cable for 4K UHD?
Expert

Re: No picture on tv when X1 box is turned on


@JCL2 wrote:
Recently bought a Samsung 4K UHD (UN55NU6900 and when I turn on the TV there is no picture but I hear the sound. It’s not a TV issue because I see the start-up screen. After I re-start the X1 box everything works correctly. I feel there is no reason to restart the box every time I want to watch tv. Using high speed HDMI cable for connection. Are there any specific setting I need to do on the box or tv so this issue doesn’t happen? Do I need a new HDMI cable for 4K UHD?

do you have the set top box plugged directly in to the TV's HDMI1 (one/first) connector? is the sound from a sound bar or the TV? If you change the cable TV channel using the remote and pressing up or down channel, does the sound change to a different channel but picture is still missing? 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: No picture on tv when X1 box is turned on

Box is plugged directly into the TV's HDMI1 (one) connector. Sound is from a sound bar which is connected to the TV using a optical cable. Yes, when I change the cable TV channel using the remote the sound changes to the different channel but picture is still missing.
Expert

Re: No picture on tv when X1 box is turned on


@JCL2 wrote:
Box is plugged directly into the TV's HDMI1 (one) connector. Sound is from a sound bar which is connected to the TV using a optical cable. Yes, when I change the cable TV channel using the remote the sound changes to the different channel but picture is still missing.

Did you follow the set-up procedure found on the Samsung television's menus (using the Samsung remote)?


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: No picture on tv when X1 box is turned on

Yes
Expert

Re: No picture on tv when X1 box is turned on


@JCL2 wrote:
Yes

When you go through the setup for devices the procedure asks if you saw the picture. If you answer "no" it should help you to fix the problem.

 

I should have added to switch you television's source on the source menu from the HDMI port over to Antenna (it doesn't matter if you don't use antenna). The switch the source back to the correct HDMI port. The television should do a fresh "handshake" with the cable box and pick up the video and audio signals.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: No picture on tv when X1 box is turned on

I will setup up the tv again and see if it fixes the issue. I will keep you updated.
Silver Problem Solver

Re: No picture on tv when X1 box is turned on


@JCL2 wrote:
I will setup up the tv again and see if it fixes the issue. I will keep you updated.

You might try different HDMI ports on the TV.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: No picture on tv when X1 box is turned on

It is not a setup issue.  Literally hundreds of people reporting this issue with the V4 boxes (including myself) and all have tried everything to no avail.  I have found that the issue seems to get 'better' if you exit the box out of any apps (like netflix or prime video) all the way out to live TV before turning off your system.  By doing this, i went from rebooting every day down to about 2 or 3 times a week.

Contributor

Re: No picture on tv when X1 box is turned on

I've had this same issue occur since a week or two ago. The only workaround fix I could find it to pass the HDMI cable through a soundbar and then to the TV. The TV seems to display the picture everytime if the HDMI cable comes from the soundbar.

 

 

New Poster

Re: No picture on tv when X1 box is turned on

I had a new tv box installed about 30 days ago and Comcast can not fix the problem. When you first turn the tv on its ok for about 10 minutes the it loses it signal every 10 minutes
Official Employee

Re: No picture on tv when X1 box is turned on

fredabarnes, oh no! Thanks for letting us know about your cable box issue. There might be some signal issues at the premise that is causing the box to lose connection with the headend. Please send me a private message with your full name for help. Just click my name and then on the next page, you'll see an option to send me a private message on the top right hand side.  


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!