Community Forum

Netflix on Xfinity X1

Frequent Visitor

Re: Netflix on X1

After posting a complaing on Twitter, a Comcast rep got with me via PM and sent a reset (or something) to my home system, and it appears to be working correctly now. I'm not totally convinced, though. Will wait and see if this happens again.

Expert

Re: Netflix on X1


Sagray wrote:

After posting a complaing on Twitter, a Comcast rep got with me via PM and sent a reset (or something) to my home system, and it appears to be working correctly now. I'm not totally convinced, though. Will wait and see if this happens again.


if you press the A button on the remote and select 'reset netflix' you can do that same task manually.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
Contributor

Re: Netflix on X1

I'm having the forgotten login info myself. We have two boxes and it's only on the DVR that it happens to. The other box is fine. Very annoying!

Frequent Visitor

Re: Netflix on X1

Andrew can you please tell me why while watching Netflix on the X1 the Dolby Digital plus is no longer working my sound system indicators only shows Dolby Digital for some reason the plus is not working but it's working on my other devices but not the X1 box thanks
Gold Problem Solver

Re: Netflix on X1

X1 does not offer Dolby Digital +... At least not yet.

We were told a while back that Comcast was working on adding DD+ but little has been said since.
Frequent Visitor

Re: Netflix on X1

I said Netflix & Netflix does FYI 

Gold Problem Solver

Re: Netflix on X1

Yes of course Netflix offers DD+. My Roku boxes and my Sony 4K Blu-ray player pass along the the DD + audio from Netflix. The X1 boxes boxes currently DO NOT pass along the DD + audio from Netflix.
Frequent Visitor

Re: Netflix on X1

Ok ill try this one more time & you need re-read my org post please, but this msg was for Andrew the expert employee or so his name says he is but I'm new on here & idk whos whom on here but anywho my post %100 clearly says the Dolby Digital + "is no longer working" as in it was since day one when X1 started using Netflix & all of a sudden for a month now its "no longer working" its only showing DD with no "PLUS" thanks Smiley Happy

Regular Contributor

Re: Netflix on X1

Whenever I use the Netflix app from my DVR, when the program starts, I have audio but no video.  So, I exit Netflix, start it up again, and this time it works. This is not sometimes, it's EVERYTIME.  I try using Netflix with Apple TV box and with my Blu-Ray player, no issues.

 

Frequent Visitor

Re: Netflix on X1


ghoofie wrote:

Whenever I use the Netflix app from my DVR, when the program starts, I have audio but no video.  So, I exit Netflix, start it up again, and this time it works. This is not sometimes, it's EVERYTIME.  I try using Netflix with Apple TV box and with my Blu-Ray player, no issues.

 


I had this issue too.   I reported it to Netflix and it was gone the next day!

Regular Contributor

Re: Netflix on X1

I did  that.  Netflix worked a short while.  Called again. They 'reset my Netflix account'. It works for a while.  I've been dealing with support every day...all they want to do is reset my box.  Problem still going on.  I even did a video of whats happening and sent it via Twitter. The reps there reply 'that's odd'. But the problem goes on.

Expert

Re: Netflix on X1


ghoofie wrote:

I did  that.  Netflix worked a short while.  Called again. They 'reset my Netflix account'. It works for a while.  I've been dealing with support every day...all they want to do is reset my box.  Problem still going on.  I even did a video of whats happening and sent it via Twitter. The reps there reply 'that's odd'. But the problem goes on.


are you able to do the reset yourself using a set top box and pressing the A button (use right to find the reset netflix).


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
Regular Contributor

Re: Netflix on X1

Yes I have the option but phone support did it. Guess I could try that. When they do the reset I don't have to relogin to Netflix. The box option A says you have to relogin, so maybe it's different. Worth a try.
Regular Visitor

Re: Netflix on X1

Does using Netflix through the X1 box count towards one's data usage cap?

Official Employee

Re: Netflix on X1


jwikoff wrote:

Does using Netflix through the X1 box count towards one's data usage cap?


Yes, any app that falls under Internet Apps counts.

New Poster

Re: Netflix on X1

I just updated my box from the store...I'm getting the message to update my box but keep getting an error that it cannot connect to the server...I tried refreshing and rebooting the new box to no avail, can you help?

Expert

Re: Netflix on X1


djvip1998 wrote:

I just updated my box from the store...I'm getting the message to update my box but keep getting an error that it cannot connect to the server...I tried refreshing and rebooting the new box to no avail, can you help?


are you receiving an error message number on the screen?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
Silver Problem Solver

Re: Netflix on X1


djvip1998 wrote:

I just updated my box from the store...I'm getting the message to update my box but keep getting an error that it cannot connect to the server...I tried refreshing and rebooting the new box to no avail, can you help?


Can you describe which box you got?

https://www.xfinity.com/support/cable-tv/x1-hub-vs-companion-box/


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Expert
Moved:

Re: Netflix on X1

Frequent Visitor

Re: X1 - Netflix

Hello,

 

I was able to get Netflix through xfinity.  Go to the apps.  Hit on Demand and the apps are there.  There is a fee for it however.

I hope this helps

Regular Contributor

Re: X1 - Netflix

For the past several weeks, LIVE TV does not resume when I exit Netflix. The screen stays black. The only way to get the LIVE TV to resume is to change the channel. I can use any of the several ways to go to a new channel, but until I do, all I have is a black screen.
Valued Contributor

Re: X1 - Netflix

Netflix revamps UI for the app

https://variety.com/2018/digital/news/netflix-tv-interface-redesign-1202877519/

No word yet as to whether comcast will implement the new UI on X1.

 

The launch of the new UI began July 18, 2018

Valued Contributor

Re: X1 - Netflix


@RadTV wrote:

Netflix revamps UI for the app

https://variety.com/2018/digital/news/netflix-tv-interface-redesign-1202877519/

No word yet as to whether comcast will implement the new UI on X1.

 

The launch of the new UI began July 18, 2018


Update

X1 has received the new UI. If you haven't received it yet, you should shortly.

Frequent Visitor

Re: X1 - Netflix

Two issues lately with Netflix:

 

1. Exiting Netflix brings you to a black screen sometimes. You have to change the channel to actually get back to seeing anything.

 

2. Not all shows on Netflix are playing. They buffer to 24% and then nothing happens. Doesn’t happen with all shows. Sometimes i can watch an episode of a show fine but another episode in the SAME show fails to load. Internet/LAN is fine. 100Mbps down and I’m a network engineer so I have a handle on what I’m doing.

 

Using the 4K X1 box.  I’d say all this started happening recently with the Netflix UI change.

Expert

Re: X1 - Netflix


@Biggen12 wrote:

Two issues lately with Netflix:

 

1. Exiting Netflix brings you to a black screen sometimes. You have to change the channel to actually get back to seeing anything.

 

2. Not all shows on Netflix are playing. They buffer to 24% and then nothing happens. Doesn’t happen with all shows. Sometimes i can watch an episode of a show fine but another episode in the SAME show fails to load. Internet/LAN is fine. 100Mbps down and I’m a network engineer so I have a handle on what I’m doing.

 

Using the 4K X1 box.  I’d say all this started happening recently with the Netflix UI change.


when you see black is there sound? did you wait for a minute to see if the commercial in progress (in an mpeg2 format on a broadcast channel) finishes (would appear black and be with or without sound)? re: your internet, depending on the X1 set top (xg1v4 in this case), it has its own DOCSIS modem and communicates separately through the Coax line. your modem can be unplugged and Netflix would still play. A Comcast employee on the forum can look at your signal levels after verifying you, or you can call 800-Comcast and select TV and ask the agent to run their tool 'interactive trouble shooting guide (einstein) to check out that xg1v4's signal levels. If not up to par, the agent can schedule a tech to come to your home. Note if the agent is unclear or says they don't know what that means, ask for a supervisor.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
Frequent Visitor

Re: X1 - Netflix


@Biggen12 wrote:

Two issues lately with Netflix:

 

1. Exiting Netflix brings you to a black screen sometimes. You have to change the channel to actually get back to seeing anything.

 

2. Not all shows on Netflix are playing. They buffer to 24% and then nothing happens. Doesn’t happen with all shows. Sometimes i can watch an episode of a show fine but another episode in the SAME show fails to load. Internet/LAN is fine. 100Mbps down and I’m a network engineer so I have a handle on what I’m doing.

 

Using the 4K X1 box.  I’d say all this started happening recently with the Netflix UI change.


I have had  the problem that you describe in #1 for a while now.  I posted it to this forum.  I have an Arris XG1V3; the issue has survived at least two DVR software releases and I had it on the old Netflix UI and now on the newer one