Community Forum

Lip Sync Issues XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix)

Regular Visitor

Lip Sync Issues XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix)

Hello.

Up until 2 weeks ago I have had zero issues with playback on my X1 XG1v4 4k box (Had for almost 1 year).  I have connected to Vizio 4K TV using HDMI and sound through Vizio Soundbar utilizing ARC. NO issues with HDR content at full resolution, or any sound issues. 

Just around 2 weeks ago we started to notice the lips did not match the audio on DVR recordings and when watching videos in the X1 Apps.  This only occurs once your fast forward or use the 30second skip feature. It can be corrected by either exiting the app/ DVR recording or swithing inputs and starting again.  This is a very frustrating experience especialy since I was so sure it was the box itself after extensive troubleshooting.

I recieved a new box on Friday and the same exact thing happens sometimes worse then the original box.  I replaced the HDMI cables as part of intitial troubleshooting and also verified by swapping to Optical sound cable using bitstream. 

This is a BOX related issue. Has there been an update that could be causing this? I do not want to order another box to just suffer with the same eratic and intermittant playback issues. Please provide some insight into this, there must be more people experiencing this issue as it looks to be related to an update to the firmware or software of the units.  

Expert

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync


@cbatty wrote:

Hello.

Up until 2 weeks ago I have had zero issues with playback on my X1 XG1v4 4k box (Had for almost 1 year).  I have connected to Vizio 4K TV using HDMI and sound through Vizio Soundbar utilizing ARC. NO issues with HDR content at full resolution, or any sound issues. 

Just around 2 weeks ago we started to notice the lips did not match the audio on DVR recordings and when watching videos in the X1 Apps.  This only occurs once your fast forward or use the 30second skip feature. It can be corrected by either exiting the app/ DVR recording or swithing inputs and starting again.  This is a very frustrating experience especialy since I was so sure it was the box itself after extensive troubleshooting.

I recieved a new box on Friday and the same exact thing happens sometimes worse then the original box.  I replaced the HDMI cables as part of intitial troubleshooting and also verified by swapping to Optical sound cable using bitstream. 

This is a BOX related issue. Has there been an update that could be causing this? I do not want to order another box to just suffer with the same eratic and intermittant playback issues. Please provide some insight into this, there must be more people experiencing this issue as it looks to be related to an update to the firmware or software of the units.  


the TV determines the 'lip sync' using a regular sync signal and a backup sync signal 1/2 second behind actual audio sync. reboot the set top box and television (remove from power) and then tune to a network talking channel and use the TV remote to adjust lip-sync (audio menu). There is no other adjustment.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync

Update : Audio is actualy lagging video so lip synch adjustments of TV and Sound bar can not correct they only offer a delay.  Was able to "re-synch" by toggeling the Game Latency option on then back off on my Vizio P55-f1 to correct this once the lip synch starts happening.

Tried several setting changes, tried Optical Audio connection, Game mode verses normal, but since its not an input lag issue none of this helps.

It seems it may be related to HDMI Handshaking issue, but I was able to get better results down scaling to 1080p. It seems the XCG1v4 box has trouble outputting 4K and audio once you start to fast forward/rewind etc in DVR recordings or Apps.

Might test by running HDMI from DVR to Soundbard and then out to TV to see it this changes anything by having audio require less decoding etc..  

Has no ONE else really seen this issue since June 01 with the 4K boxes???

Expert

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync


@cbatty wrote:

Update : Audio is actualy lagging video so lip synch adjustments of TV and Sound bar can not correct they only offer a delay.  Was able to "re-synch" by toggeling the Game Latency option on then back off on my Vizio P55-f1 to correct this once the lip synch starts happening.

Tried several setting changes, tried Optical Audio connection, Game mode verses normal, but since its not an input lag issue none of this helps.

It seems it may be related to HDMI Handshaking issue, but I was able to get better results down scaling to 1080p. It seems the XCG1v4 box has trouble outputting 4K and audio once you start to fast forward/rewind etc in DVR recordings or Apps.

Might test by running HDMI from DVR to Soundbard and then out to TV to see it this changes anything by having audio require less decoding etc..  

Has no ONE else really seen this issue since June 01 with the 4K boxes???


the video and audio are streams. the lipsync moves the video relative to the audio so it can be lead to lag direction. the setting is separate for each input source and adjusting one does not affect the other inputs.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync

I have. Exactly as you describe. Scary-exactly, from what provokes the lost sync to getting another box (ok, two other boxes). I'm about to try the fixes offered on this page. But you are no way alone
Expert

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync


@gdbloom wrote:
I have. Exactly as you describe. Scary-exactly, from what provokes the lost sync to getting another box (ok, two other boxes). I'm about to try the fixes offered on this page. But you are no way alone

lip-sync is done by the TV and is managed per device in TV memory. use the TV remote, audio menu, lip-sync and a live news channel to do the setting.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1v4 DVR Recording Playback and Apps (Amazon, Tubi,Netflix) issue with Audio and Video Sync

My TV will sometimes go wildly out of sync - like by seconds, and it is usually after using some internal TV app and then switching back to HDMI input.   Restarting the TV always fixes it but I'd like to find something faster and more convenient.   I've seen a suggestion to try switching to another HDMI input and back which I haven't tried yet - but I don't think my TV will even let me select an input that does not have an active device.