Community Forum

Have sound but no picture.

New Poster

Have sound but no picture.

My cable has sound but no picture. Guide screens come up but the actual channels do not. 

 

 

Silver Problem Solver

Re: Have sound but no picture.

Did you reboot the box?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Have sound but no picture.

Thanks for suggestion.
The same happened to us last night.
To reboot, do we just unplug the box for a few seconds?
Silver Problem Solver

Re: Have sound but no picture.


@KK42679 wrote:
Thanks for suggestion.
The same happened to us last night.
To reboot, do we just unplug the box for a few seconds?

Yes

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: Have sound but no picture.

Tried to vie YouTube then lost picture
Silver Problem Solver

Re: Have sound but no picture.


@nhb51 wrote:
Tried to vie YouTube then lost picture

Try a system refresh.

https://www.xfinity.com/support/articles/x1-system-refresh

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Have sound but no picture.

Have sound but know picture
Silver Problem Solver

Re: Have sound but no picture.


@Kpmello wrote:
Have sound but know picture

Try a system refresh.

https://www.xfinity.com/support/articles/x1-system-refresh

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Have sound but no picture.

We trird, but no help.  Any other ideas?

Silver Problem Solver

Re: Have sound but no picture.


@johnphyl wrote:

We trird, but no help.  Any other ideas?


Is it only a TV connected to an X1 box?  No separate sound system?  Which X1 box?

https://www.xfinity.com/support/articles/x1-hub-vs-companion-box

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Have sound but no picture.

Have sound but no picture
Silver Problem Solver

Re: Have sound but no picture.


@Jax333 wrote:
Have sound but no picture

Reseat all connections and reboot the X1 box.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Bronze Problem Solver

Re: Have sound but no picture.

Hello, I would like to look into this for you from here. To protect the privacy of your account, can you provide your full name exactly as it's listed on the billing statement? To send a private message click on my name, then click "Send a message".


I am a Retired Official Comcast Employee and no longer actively support the Xfinity Forum.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: Have sound but no picture.

I bought new Sony/Bravia TV,
I see channel guide and TV HDMI connection got changed to Comcast. However, I receive a message "no signal, check the external input or select another input using input button. I tried 3 TV HDMI slots to no avail and have Comcast reset the box. Any suggestions?
New Poster

Re: Have sound but no picture.

System refresh is not obtainable without a picture...

Official Employee

Re: Have sound but no picture.

Hi All, if you're still unable to see picture, please send me a private message with your full name so I can help. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Silver Problem Solver

Re: Have sound but no picture.


@dmogie wrote:

System refresh is not obtainable without a picture...


Try changing the HDMI source on the TV with the TV remote.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Have sound but no picture.

Simply reboot the box by unplugging the power for 10 - 30 seconds (or more).  Plug it back in and wait for it to refresh the channels.  Glitch happens.

New Poster

Re: Have sound but no picture.

Hi
I have this issue since I plugged the HDMI cable.
Expert

Re: Have sound but no picture.


@Zulfikar wrote:
Hi
I have this issue since I plugged the HDMI cable.

do you have the HDMI cable connected directly to your TV or via the receiver/soundbar? is the TV connection HDMI1 (one)?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Have sound but no picture.

My tv hard to start each morning with a picture. I have good sound but no picture

Silver Problem Solver

Re: Have sound but no picture.


@roberth_smith2 wrote:

My tv hard to start each morning with a picture. I have good sound but no picture


Re-seat the HMDI cable on the X1 box and the TV first.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!