Community Forum

HDMI port stopped working

New Poster

HDMI port stopped working

Everything was working fine until the tv started showing the no signal message. Tried replacing the hdmi cable, using a different port, restarting everything, unplugging, etc. The problem went away once the box was replaced. Now a few weeks later the problem has returned. I tried using a coax cable and the box seems to work normally but HD cant work over coax. Any ideas?
Tags (1)
New Poster

Re: HDMI port stopped working

I want to add that I confirmed that the tv is working by connecting another device via hdmi.
Expert

Re: HDMI port stopped working

This seems to happen most often to Sony "smart" televisions. It's been an issue for more than a year now. You could try (using the tv remote) switch the source to another port. Then back to the correct port for HDMI cable. If that does not work, then unplug the X1 box for over a minute. Plug it back in to allow reset.

This usually works but is a real pain in wasted time.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: HDMI port stopped working

I have the same issue.... Comcast/Xfinity has no solution.
New Poster

Re: HDMI port stopped working

The same issue is with Toshiba TV... Xfinity box has a defective hdmi connection and they will not take ownership and fix it.
Silver Problem Solver

Re: HDMI port stopped working


@Len3 wrote:
The same issue is with Toshiba TV... Xfinity box has a defective hdmi connection and they will not take ownership and fix it.

If the HDMI port on the X1 box is defective, the only fix is to go to the nearest Xfinity Store and do a free swap.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: HDMI port stopped working

It is June 2019 and the technician still does not have a clue why this is happening. I have to reboot every morning and evening
Silver Problem Solver

Re: HDMI port stopped working


@Kayala1 wrote:
It is June 2019 and the technician still does not have a clue why this is happening. I have to reboot every morning and evening

Did you try the free swap option?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: HDMI port stopped working

Kayala1, I'd be happy to swap out your box! Sorry to hear about the service issues on your TV. Please let me know if you'd like to try a box swap. 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: HDMI port stopped working

It is not the box, this is my second one.  It is not the TV.  It seems to be some kind of communicating problem with the boxes.  No one seems to know what the fix is.

New Poster

Re: HDMI port stopped working

on my 2nd box

Official Employee

Re: HDMI port stopped working

Got it, Kayala1! Are you using the xg1v4 (4K) DVR by chance? 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: HDMI port stopped working

I am on my 6th cable box in the last 12 months with this same exact problem: hdmi port failure. The tech comes out, swaps the box, signal returns for exactly one day, then no video messages the next day.

One time the signal died while the tech was there and then again 20 minutes after he left.

It's not my tv, we've swapped that out even though there is no problem getting signal from other hdmi sources. HDMI cable itself has been changed 6x. The coax was completely replaced behind the wall to the outside.

We put a power surge protector in case it's getting zapped to no avail.

The only thing that has not been replaced so far is the line from the street to the house.

Techs know nothing. The last one suggested I use component outputs instead and he set it up that way, which came out black and white, grainy and small with no sound. I forced him to swap out the box and just let him leave bc he was clueless.

2nd tech for the week arrives Friday.

New Poster

Re: HDMI port stopped working

Sounds like i'm having a simular problem.

I have a small X1 box in my master bedroom that I have to reset atleast every other day.

It's hook up via hdmi cable.

Turn on says no signal-reset box by unplugging power to it.

This also is my second box-had wireless box before that could not keep signal.

New Poster

Re: HDMI port stopped working

I have the same problem and was told to switch my box. Took it to the Comcast place yesterday, brought box home, hooked it up and same blue screen with the message that says no signal detected. Been going on about six months and what we have been doing is just using the input button on the remote to cycle back around to the hmdi input the receiver is on and it comes in that way rather than shutting down the receiver and waiting for it to reboot. Still frustrating as heck and a solution in another forurm states the problem is from the HDMI cable not getting a signal from Comcast. Two tech I have told this two over the phone and neither understood what it meant. SO the struggle is real. Real annoying!

Official Employee

Re: HDMI port stopped working

Hi diadem. Thanks for posting in our Forum. Are you experiencing this trouble using our new 4K DVR, the XG1v4 model? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: HDMI port stopped working

Same here. Model ax013anm
Silver Problem Solver

Re: HDMI port stopped working


@drbandkgb wrote:
Same here. Model ax013anm

Did you try unplugging and plugging back in both ends of the HDMI cable?  Mine wasn't completely seated.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: HDMI port stopped working

Yup. We have also different hdmi cables and other components to ensure it wasn’t a TV issue. And nope... definitely the cable box.
Silver Problem Solver

Re: HDMI port stopped working


@drbandkgb wrote:
Yup. We have also different hdmi cables and other components to ensure it wasn’t a TV issue. And nope... definitely the cable box.

I hate to say it, but one option is to take the box to the nearest Xfinity Store and get a free swap.  The new box comes in a package with everything, including another remote.  If you swap, don't use the old power supply - it has been known to cause issues.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: HDMI port stopped working

I had to go back to the non 4k box, comcast cannot get the 4k boxes to work.

Silver Problem Solver

Re: HDMI port stopped working


@Kayala1 wrote:

I had to go back to the non 4k box, comcast cannot get the 4k boxes to work.


Just an FYI, I have two 4k boxes and they have never had any issues.  Maybe we have different setups.  Did Comcast install a lossless splitter?  Mine is in the attic.EVO1-9-UU(2).jpg

 

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: HDMI port stopped working

We have two X1 DVR boxes.  On Wednesday night, BOTH stopped outputting any signal on the HDMI port - TVs show "no input" - we've tried multiple TVs, multiple inputs on each TV, and multiple HDMI cables.  Had been fine for months.  

 

Oddly, the composite output is working fine on both.  So I was able to try setting different output resolutions just in case that helped.  Nope, nothing - the HDMI port is not active.

 

No explanation, we're waiting for techs to come out next week.  

 

 

Official Employee

Re: HDMI port stopped working

thereis, thanks for posting on the forums. Definitely a strange case. Sounds like there may be a possible issue with the box or maybe signal flux at the premise that is causing the handshake error. When is the tech scheduled to arrive? 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!