Community Forum

Getting the RDK-03003 Error.

Regular Visitor

Getting the RDK-03003 Error.

My internet was spotty earlier in the day. I replaced the existing comcast provided "Ubee" modem with the new Cisco Xfinity modem. 

 

When i called customerservice to activate the modem, all my TV's just froze. After firmware download etc, the modem is back online, however the X1 boxes are down. then show "Reboot" in the display panel and RDK-03003 error message. Telephone is down as well.

 

any thoughts?

Highlighted
Contributor

Re: Getting the RDK-03003 Error.

Have you tried restarting each box?

 

Read more about troubleshooting that error code here: http://customer.xfinity.com/help-and-support/cable-tv/x1-errorcode-rdk-03003-unable-to-connect-to-xf...

Official Employee

Re: Getting the RDK-03003 Error.

I would call back in, ask them to check all your rate codes

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Gold Problem Solver

Re: Getting the RDK-03003 Error.

Andrew,

Did you take a look at Giyer's signal levels? Spotty internet and phone is out in combination with RDK-03003 sure suggests signal issues...


@ComcastAndrew wrote:
I would call back in, ask them to check all your rate codes



 

Official Employee

Re: Getting the RDK-03003 Error.

Because the OP wasn't having X1 issues until the phone call, it's not a signal issue. Op was swapping a modem for gateway. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Silver Problem Solver

Re: Getting the RDK-03003 Error.


@ComcastAndrew wrote:

Because the OP wasn't having X1 issues until the phone call, it's not a signal issue. Op was swapping a modem for gateway. 


Sorry, but I'd disagree based on the error, and say that it's a coincidence that the boxes lost their signals at the same time the modem was activated. Perhaps OP changed a splitter and didn't hook it up right?

 

03003 = no signal

Regular Visitor

Re: Getting the RDK-03003 Error.

Problem solved:

 

IT was an issue with the connection to the amplifier. The tech replaced the cable and everything worked fine