Community Forum

Downgraded service, "Free to me" not working

Highlighted
New Poster

Downgraded service, "Free to me" not working

I recently downgrated from the top of the line package to the 140+ channels package. I'm trying to get the "Free to me" guide option to work, but it's still showing ALL the premium channels.

 

I've done both a quick and a deep reset of the box, but neither helped.

 

Any ideas how I filter out stuff I no longer have access to?

 

Thanks in advance!

 

Steve

Frequent Visitor

Re: Downgraded service, "Free to me" not working

I had the same problem for months after swapping one premium channel for another.  Even though I couldn't view the old selections...both the old and the new showed up in the "free to me" sort.  Reboot...software refresh...nothing helped.   I suggest contacting customer service.  For some reason, it seems they have to manually "push" your account subscription details across to the X1 system.  They did that yesterday on my account and finally the "free to me" sort appears correct.

New Poster

Re: Downgraded service, "Free to me" not working

Turns out all I had to do was leave town for a week to a conference. When I got back, it was finally in place.. Only took 2 weeks for the box to figure it out.

 

Steve

 

Official Employee

Re: Downgraded service, "Free to me" not working

parkerpress, thanks for the update! When a service change is done, the box sometimes takes a little time to adjust to your new channel entitlements. If you use the refresh button via the troubleshooter included in your X1 box, that is a great way to get this started. 

 

Check it out: https://www.xfinity.com/tips/restart-your-xfinity-x1-cable-box


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!