Community Forum

x1 keeps freezing up and losing signal

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

x1 keeps freezing up and losing signal

x1 box keeps freezing up and losing signal when browsing channels or do multiple operations at once during heavy load.... do I need a technician to give me a frequency booster or ?

Official Employee

Re: x1 keeps freezing up and losing signal

You probably need a tech out to verify your work, since you did a self install.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: x1 keeps freezing up and losing signal

Hi, zeroxzerotwo - I can help with scheduling a tech visit as well as answer any billing questions you have. Provided instructions for private messaging in your other post.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: x1 keeps freezing up and losing signal

nah it's all good... im calling tuesday. I'll be sure to get everything free of service because this is unacceptable