Community Forum

picture flickering

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

picture flickering

Just switched back to xfinity and picture is flickering or pixelating. Had a plug in amplifier with cable attached from previous account but cannot remember if it is for internet or tv. Does anyone know what amplifier is for?

Official Employee

Re: picture flickering

It depends on what the model of amp is. Maybe have a tech out to troubleshoot further

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

amplifier installation

Can someone please tell me how to wire an amplifier to the splitter. Does main cable wire go to the in connector and the amp on the out?

Official Employee

Re: amplifier installation

What kind of amplifier and splitter? Post a pic if you can, you can only use certain types without having more issues

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: amplifier installation

It is an AC Adaptor, Model AD35-1200200DU, Input 120v - 60Hz 45mA, Output 12v 200mA. Just came back to comcast and this was installed previously. My picure is pixelating and I think this was installed before to stop that. Not sure how it was installed to splitter that then went to a 4 way splitter for my tv's and internet.

Official Employee

Re: amplifier installation

That sounds like the model of the power supply. Have a tech out to troubleshoot properly and install the proper amp

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: amplifier installation

The actual amplifier is SV-15PRS-m, 15 dB. 53-1000MHz, Passive reverse path 5-42MHz, 12vdc 200mA

Official Employee

Re: amplifier installation

That amp would’ve worked for your previous setup, it’s not the right one for the X1 boxes

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!