Community Forum

parental controls blocking me!

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

parental controls blocking me!

I've been watching the game of thrones series online and I made it through the entire first season with no problems but for some reason today I can't play any of the episodes. A message pops up saying it's rated TV-MA and to manage my parental controls. I don't have any parental controls on. I've checked several times, and there is definitely no parental controls. I even tried turning them on and trying to work through it that way but nothing. I've tried opening the video in different internet browsers and none of them work. I'm on google chrome now and it's the most updated version. I don't know what to do, but I'm getting really annoyed! I want to finish my show. 

New Poster

Re: parental controls blocking me!

I just had the same thing happen trying to watch Robot Chicken! I am not a parent and there are no kids around, but I get that same message.