Community Forum

fix vizio tv set up screen that is stuck on language selection

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Re: fix vizio tv set up screen that is stuck on language selection

Just got off the phone with tech support: try all remotes that are connected to the tv (ie - dvd, amplifier or cable box) I know I was surprised too (it was my amp remote)
Hope this helps
Frequent Visitor

Re: fix vizio tv set up screen that is stuck on language selection

It did not work for me
New Poster

Re: fix vizio tv set up screen that is stuck on language selection

Hi,, today i got the solution for the problem 'Tv Stuck On Language Screen"
I have Skyworth Lcd and it was stuck on Language screen 4 days back, i've tried every sigle App and Different Universal Remotes and buttons on Tv but nothing was working except a single App named "SURE UNIVERSAL REMOTE FOR TV"
i suggest if someone face this Language screen stucking problem and no buttons and remotes are working then you should download this App on your Cell phone and select your tv and you'll surely be able to restore your Tv.
Silver Problem Solver

Re: fix vizio tv set up screen that is stuck on language selection

Unplug the coax and the power to the STB.  Wait a minute, then plug the coax in first and then plug in the power.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

fix vizio tv set up screen that is stuck on language selection

Please HELP! We just are trying to connect and pair our remote with the X1 DVR box. The initial setup looked like it was working, but then the language selection menu appeared and it apparently is frozen in place. How do we fix this?