Community Forum

Xfinity YouTube app 4K issue

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Xfinity YouTube app 4K issue

I recently got a XG1v4 box to play 4K content on my 4K TV. The issue I’m having is with the native YouTube app. The first day I used it the app displayed 4K just fine. I used the resolution monitor in the app and double checked all the indicators such as 4K labels and etc on the videos that were playing to make sure. The next day I go to use the app for some reason will not show videos in 4K anymore. They will max out at 1080p/60 when I check the monitors and yes I am triple checking to make sure the uploaded content is in 4K. I am confused because It was literally working fine the first day I set it up. Any information on fixing this will be helpful. Thanks!

Silver Problem Solver

Re: Xfinity YouTube app 4K issue

I can't find any mention of X1 supporting 4k YouTube.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Expert

Re: Xfinity YouTube app 4K issue

If you have a smart tv, download and use the You Tube app found on your smart tv. The app found there always identifies your tv as 4K and will play the apps in 4K if your broadband is around 15 Mps. A little less will work if you have very few other devices turned on and using the internet at the same time.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!