Community Forum

X1 plarform

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Re: X1 plarform

First thing to try is pull power cord from Xfinity cable box (assuming no power switch on the thing), wait at least 20 to 30 seconds, then plug the cord back in.  That was enough for me to get past the " welcome to the X1 platform.   Connecting to your entertainment experience" message.  It takes a couple of minutes for the box to reboot so be patient.

Official Employee

Re: X1 plarform


Ashlynlaporte wrote:

The screen is stuck on “ welcome to the X1 platform.   Connecting to your entertainment experience 


Looks like you're in outage with an ETR of 1:56 am EST

Expert

Re: X1 plarform


Ashlynlaporte wrote:

The screen is stuck on “ welcome to the X1 platform.   Connecting to your entertainment experience 


call 800-Comcast. select TV technical support. The agent will check what is happening and schedule a fix for the problem.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
New Poster

X1 plarform

The screen is stuck on “ welcome to the X1 platform.   Connecting to your entertainment experience