Community Forum

X1 Factory reset

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

X1 Factory reset

My X1 was working fine except that our second x1 box would freeze from time to time.  My wife called to let Comcast know of the issue and the lady she got said the problem was our main DVR was not activated and this is why the second box was freezing.  My wife told her our DVR works just perfect and it has been activated for months.  The tech did not listen and did something which completely stopped our main X1 DVR from working.  Now when it boots it gets to an error screen that says "This device needs to be activated before we can continue". XRE-00250. Strangley enough the master bedrroom box is still working.  I have spoke with 3 different tech via phone, 1 tech via chat, and the billing department and no one can fix the issue.  They want to send a tech to our house.  How is it that it can get messed up via phone but cannot be fixed as such.  I would really just like to get the box back to a factory reset so I can go through the activation process, I believe that will fix the issue.  For some reason that is a big secret, but I see it gets PM'd here all the time.  Please if you can help please PM these instructions so I can enjoy my X1.

 

 

New Poster

Re: X1 Factory reset

Comcast Andrew any help would be greatly appreciated!

Official Employee

Re: X1 Factory reset


reelmagic wrote:

Comcast Andrew any help would be greatly appreciated!


Doesn't sound like a factory reset you need as much as you need it back on your account and re-activated in the back end, try 877-896-8678.

New Poster

Re: X1 Factory reset

I spoke to billing because tech support thought the same thing, but biling said everything was fine.  Another tech that billing then sent me to, said the box looked activated to her as well.  But whatever the first tech did messed it up.  Thats why I thought if I did a factory reset so I could go through the activiation process it would reestablish the connection.

Official Employee

Re: X1 Factory reset

You're welcome to try but you will probably end up at the error code screen that you have now. Check your PMs

Gold Problem Solver

Re: X1 Factory reset


An on site tech would probably have you up and running in less than 10 minutes and the tech would also be able to do an on site signal check which is critical with X1 boxes.


New Poster

Re: X1 Factory reset

It worked as I expected.   Thank you very much.

 

I am ok with a tech coming to look at my original problem with the freezing on the second box, but what upsets me is that someone at Comcast, God knows where, messes up my main TV and NO ONE CAN FIGURE OUT HOW TO FIX IT!!!  Yet the one simple thing I asked for, a factory reset, had me up and running in 3 minutes!!  Thanks again Andrew.

Official Employee

Re: X1 Factory reset


reelmagic wrote:

It worked as I expected.   Thank you very much.

 

I am ok with a tech coming to look at my original problem with the freezing on the second box, but what upsets me is that someone at Comcast, God knows where, messes up my main TV and NO ONE CAN FIGURE OUT HOW TO FIX IT!!!  Yet the one simple thing I asked for, a factory reset, had me up and running in 3 minutes!!  Thanks again Andrew.


Glad you got it going, sorry you had to do it in the first place.

New Poster

Re: X1 Factory reset

Could someone help me with the factory reset?  I am having the same problem and can't get someone out for over a week.  This is the only box I have, am have no TV.  Frustrating!

 

New Poster

Re: X1 Factory reset

Andrew, could you help.  I am froze on the "boot" menu for hours.  Contacted comcast with no help.  Sending a tech out in a week!  This is my only box, I have no TV...

 

Thanks,

Bill

Silver Problem Solver

Re: X1 Factory reset

Try unplugging the power AND the coax connection at the same time, wait at least a minute and replug them back in.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Regular Contributor

Re: X1 Factory reset

Good Morning lofts13,

 

I definitely understand your frustration. I show you have a service appointment today between 12:00PM-2PM. If you are still having issues after the technician visit, please feel free to reach out to us and we will be happy to further address your concerns. 




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: X1 Factory reset

ComcastAndrew, I'm experiencing the same issue - moved to new home with X1, my old address and account number are stuck on the "my account" page on my TV, my account seems to be updated online, and I'm unable to record programs and my OnDemand asks me to subscribe to channels I already have. How can I update my account information on my box?! I've refreshed dozens of times and spent hours on the phone with no success! I beleive a factory reset of the box seems to be the solution to this?

Tags (1)
Official Employee

Re: X1 Factory reset

I responded to your private message with a couple of options