Community Forum

Wont play Banshee (Error age-anon)

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Wont play Banshee (Error age-anon)

I am trying to watch the latest episode of Banshee (Cinemax) and it keeps showing a message saying "This video can not be played, the episode is currently unavaliable, (Error age-anon)"

It id showing this message for every Banshee episode I click on but any other show I try to watch works fine. How do I fix this??

New Poster

Re: Wont play Banshee (Error age-anon)

This happened to me and when I tried playing Game Of THrones on my ipad it played. I have also logged out and then back in. That worked a couple of times.  COMCAST FIX THIS BUG