Community Forum

Unable to setup XID-C set top box

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Re: Unable to setup XID-C set top box

Thanks for yor reply!. 

I have only one TV. The cable box which had DVR was costing $10 more. So I returned it and got a new cable box without the DVR capability from comcast store.  This did not work for some unknown reason. So when I called up the Chat support , they troubleshooted and after that sent the XID-C box and then disabled the cable box given by the comcast store. Seems chat support person did not know the XID-C box will not work alone !!!! I spent the next day trying to troubleshoot the XID-C.  Finally called the technician for home visit.  He for some reason thought my internet modem has some issue and replaced it with a different internet modem. ( I stil dont know what internet modem has anything to do with the cable modem as they both get separate connections via the splitter. ) And he also removed the old-cablebox , xid-c box and then replaced with another cablebox and finally it all started working.  

 
Official Employee

Re: Unable to setup XID-C set top box


@NellaiRayan wrote:

Hi Everyone,

 

I returned my set-topbox with DVR to the comcast local store as I didn't want the DVR capability anymore. And got a XG2V2-P box as a replacement.  This did not cross the 'English' language selection. I reached out to CHAT support and after validation decided to send another box via mail. The new box is XID-C box and this keeps resulting in 'RDK-03036' error. 

 

 

Setup Details:

wall outlet goes to a splitter. One end goes to the Internet box. Another end goes to the XID-C cable box. 

Tried powercycling. 

Tried plugging this directly to the wall outlet.

 

After displaying the welcome screen, it results in the pinkish 'Somethings not quite right' (RDK-03036) message.

Anything else I can try ? Technician is available only after wed.

 

Thanks

 

 

 


Adding, plug the XG2 back in and then follow the above instructions.

Expert

Re: Unable to setup XID-C set top box


@NellaiRayan wrote:

Hi Everyone,

 

I returned my set-topbox with DVR to the comcast local store as I didn't want the DVR capability anymore. And got a XG2V2-P box as a replacement.  This did not cross the 'English' language selection. I reached out to CHAT support and after validation decided to send another box via mail. The new box is XID-C box and this keeps resulting in 'RDK-03036' error. 

 

 

Setup Details:

wall outlet goes to a splitter. One end goes to the Internet box. Another end goes to the XID-C cable box. 

Tried powercycling. 

Tried plugging this directly to the wall outlet.

 

After displaying the welcome screen, it results in the pinkish 'Somethings not quite right' (RDK-03036) message.

Anything else I can try ? Technician is available only after wed.

 

Thanks

 


do you still have the xg2? if so, using the remote for the xg2 press and hold the setup until the remote's LED changes color. press 987 - you should then be able to do the menu to set up the set top box. the Xic can't work on an x1 system without an xg1 (DVR) or an XG2 (satellite).


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
New Poster

Unable to setup XID-C set top box

Hi Everyone,

 

I returned my set-topbox with DVR to the comcast local store as I didn't want the DVR capability anymore. And got a XG2V2-P box as a replacement.  This did not cross the 'English' language selection. I reached out to CHAT support and after validation decided to send another box via mail. The new box is XID-C box and this keeps resulting in 'RDK-03036' error. 

 

 

Setup Details:

wall outlet goes to a splitter. One end goes to the Internet box. Another end goes to the XID-C cable box. 

Tried powercycling. 

Tried plugging this directly to the wall outlet.

 

After displaying the welcome screen, it results in the pinkish 'Somethings not quite right' (RDK-03036) message.

Anything else I can try ? Technician is available only after wed.

 

Thanks