Community Forum

TiVo Bolt On Demand gives screen with CableCARD ID, Host ID, Data

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

TiVo Bolt On Demand gives screen with CableCARD ID, Host ID, Data

I just got Xfinity and everything works fine except On Demand.  I can browse and select shows but as soon as I press Play, I get the cable card screen as if it isn't activated.  I've tried calling 877-405-2298 as listed on the screen but that just gets me to regular support who are clueless when it comes to TiVo and cable cards.  They just say to call TiVo tech support.  From what I've read on here, Xfinity techs on here have been able to fix the problem for others so I hope one of you can fix it for me.

New Poster

Re: TiVo Bolt On Demand gives screen with CableCARD ID, Host ID, Data

Turns out it's not just my On Demand.  Several of my channels are doing the same thing.  I've called support 4 or 5 times and am currently waiting for a call back from the higher up tech team.  I was told they would call within 24 hours.  That was 2 and a half days ago.  Now I remember why I left Comcast to begin with.  If they don't call me tomorrow, I think I'll cancel the service and go back to WOW.  While they don't offer as much, at least their support is competent and responsive.  This is ridiculous!

New Poster

Re: TiVo Bolt On Demand gives screen with CableCARD ID, Host ID, Data

I don't have a solution, but I have the same problem on my tivo premiere with a cablecard. I can see all my channels, but my on demand experience is exactly as you describe. Comcast tech support was easy to get hold of for me, at least, but they weren't able to help. I'm going to call again and ask them to escalate it to tier 2.