Community Forum

The Xfinity X one remote will not change channels

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Official Employee

Re: The Xfinity X one remote will not change channels


Jbachelder wrote:
Anyone know what the resolution was here? My remote was working just fine yesterday, but now it’ll only turn the TV on/off. Flashes a quick green/red when any other button is pushed - no response from TV. I have a voice remote.

Try resetting your dvr

New Poster

Re: The Xfinity X one remote will not change channels

Anyone know what the resolution was here? My remote was working just fine yesterday, but now it’ll only turn the TV on/off. Flashes a quick green/red when any other button is pushed - no response from TV. I have a voice remote.
Official Employee

Re: The Xfinity X one remote will not change channels


Melzack wrote:
We have the Xfinity X1 remote. It will let me turn the TV on and off but will not change channels It's only showing red when I push any of the buttons. I have switched out The batteries, twice. There was an update on our box last night, I think, because it was flashing the blue light quite a bit. I don't know if that has anything to do with it. We have the new Xfinity X1 box so there are no buttons to push and I tried to reset that by unplugging it, waiting 30 seconds, and then plugging it back in, to no avail.

Have you tried the remotes from any of your other boxes? You have 7 boxes, which is it?

Visitor

The Xfinity X one remote will not change channels

We have the Xfinity X1 remote. It will let me turn the TV on and off but will not change channels It's only showing red when I push any of the buttons. I have switched out The batteries, twice. There was an update on our box last night, I think, because it was flashing the blue light quite a bit. I don't know if that has anything to do with it. We have the new Xfinity X1 box so there are no buttons to push and I tried to reset that by unplugging it, waiting 30 seconds, and then plugging it back in, to no avail.