Community Forum

Re: Continuing Comcast X1 TV pixilation problems and screen freezing

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Re: Continuing Comcast X1 TV pixilation problems and screen freezing

New to the Forum. Really frustrated. I have had all of the technical assistance both remote and in-house possible with regard to the same issue. My picture is freezing, ghosting and pixilating. One tech replaced a booster and it worked for a feew days and then reappeared; one tech said he found a cable in to the box that had deterioarted and that fixed it for a few days. Yesterday, Comcast shipped what they identify as the new 4K box and said it may be a way to resolve. I have yet to hook it up. I'm not sure which older X-1 box was the master box among a large number of X-1s in my home. Any advice on all of this? I will try to report back after hooking up the 4K box. This "new" box is identified as XG1v4-A. In that same Comcast box were two smaller boxes identified as Xid-C. Any ideas?   Our neighborhood system is niot fiber.Inside house wiring is Cat 5. Thanks all.

Official Employee

Re: Continuing Comcast X1 TV pixilation problems and screen freezing

 

ballys, please connect your new DVR box and let us know if you see improvement in picture quality. If not, I'll take a look at your signal levels. 

 

KenF