Community Forum

Randomly changes to non-HD {movie channels only}

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Contributor

Randomly changes to non-HD {movie channels only}

I notice when I use the right arrow button to bring up the channel list and I choose a Cinemax, Showtime , etc .. HD channel it sometimes changes it to the non-HD channel and I have to go back and redo.

Thoughts?
Silver Problem Solver

Re: Randomly changes to non-HD {movie channels only}

Use the A button and do a system reset and see if it fixes it.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Contributor

Re: Randomly changes to non-HD {movie channels only}

That didn't help. Thx.

I even selected movie channel #1862 from the Last Watched menu and it sent me to #352 which is non-HD.

The second time I tried it went to #1862.

Selected a Showtime HD station from Channel menu and it sent me to the equivalent non HD.

Odd!
Silver Problem Solver

Re: Randomly changes to non-HD {movie channels only}


@desmo907 wrote:
That didn't help. Thx.

I even selected movie channel #1862 from the Last Watched menu and it sent me to #352 which is non-HD.

The second time I tried it went to #1862.

Selected a Showtime HD station from Channel menu and it sent me to the equivalent non HD.

Odd!

A lot of my channels appear as both SD and HD in the channel numbers below 1000.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Contributor

Re: Randomly changes to non-HD {movie channels only}

Yes mine also but when i specifically select an HD (over 1000) it randomly selects the non HD and then I have to go find it again and select again. Very odd.

This seems to only happens with with movie pay stations like Showtime, etc.