Xfinity plant
Community Forum
Xfinity globe

Purple screen

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Purple screen

Whenever I turn my TV on, the black and red xfinity screen flashes, then after about five seconds a light purple screen appears and I have no access to cable. The box is connected to HDMI 2, and my roommate's dad, who works in IT, thinks everything is plugged in correctly. Is this a problem with the service or something we can fix?
Expert

Re: Purple screen


alisonsears wrote:
Whenever I turn my TV on, the black and red xfinity screen flashes, then after about five seconds a light purple screen appears and I have no access to cable. The box is connected to HDMI 2, and my roommate's dad, who works in IT, thinks everything is plugged in correctly. Is this a problem with the service or something we can fix?

if you turn off your TV then after a few seconds turn it back on is picture and sound then working? Does the TV power light stay on? you can try putting the X1 box in SD mode by pressing Exit Exit Exit 480  (to change back exit exit exit 720 or use your device settings menu)

Official Employee

Re: Purple screen

 

Hi alisonsears, it sounds like your HDMI cable is bad. If you can get the picture to flicker and work after giggling the cable then your HDMI cable is the problem. I show that you have more than one cable box, do you get the same issue on all of them?