Community Forum

Pairing Vizio TV and Sony Sound Bar with X1 Voice Remote

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Pairing Vizio TV and Sony Sound Bar with X1 Voice Remote

I am trying to pair my Xfinity remote with a Vizio TV and a Sony HTC150 sound bar and subwoofer.  I used an HDMI out from the cable box to the subwoofer and an HDMI ARC cable from the subwoofer directly to the TV.  When I try to pair the TV, it thinks it is looking for a Sony TV not a Vizio TV (I think because the ARC cable is directly from the Sony subwoofer to the TV).  Should I be looking for Vizio codes instead of the Sony codes that I think it's giving me?  

Expert

Re: Pairing Vizio TV and Sony Sound Bar with X1 Voice Remote


JBNebel wrote:

I am trying to pair my Xfinity remote with a Vizio TV and a Sony HTC150 sound bar and subwoofer.  I used an HDMI out from the cable box to the subwoofer and an HDMI ARC cable from the subwoofer directly to the TV.  When I try to pair the TV, it thinks it is looking for a Sony TV not a Vizio TV (I think because the ARC cable is directly from the Sony subwoofer to the TV).  Should I be looking for Vizio codes instead of the Sony codes that I think it's giving me?  


you might try connecting the X1 set top box directly to the TV and running setup on the remote (first).




I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Official Employee

Re: Pairing Vizio TV and Sony Sound Bar with X1 Voice Remote


JBNebel wrote:

I am trying to pair my Xfinity remote with a Vizio TV and a Sony HTC150 sound bar and subwoofer.  I used an HDMI out from the cable box to the subwoofer and an HDMI ARC cable from the subwoofer directly to the TV.  When I try to pair the TV, it thinks it is looking for a Sony TV not a Vizio TV (I think because the ARC cable is directly from the Sony subwoofer to the TV).  Should I be looking for Vizio codes instead of the Sony codes that I think it's giving me?  


Yes, look for Vizio codes. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!