Community Forum

Once a day my TV says "no signal" but green light is on

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

Once a day my TV says "no signal" but green light is on

About once a day when we go to watch TV, we push the All Power button, the TV goes on, the green light on the XG2 is on, but the TV says there's no signal. Pushing various buttons on the X1 remote doesn't bring anything up. The only thing we can figure out is to push the power button on the device directly. The first push turns the light off, the second turns it back on, and then all is well.

 

Any idea what the issue is?

 

If it matters, the TV is an LG OLED65C7P. HDMI cable.

-- Ethan

 

Expert

Re: Once a day my TV says "no signal" but green light is on


foggyethan wrote:

About once a day when we go to watch TV, we push the All Power button, the TV goes on, the green light on the XG2 is on, but the TV says there's no signal. Pushing various buttons on the X1 remote doesn't bring anything up. The only thing we can figure out is to push the power button on the device directly. The first push turns the light off, the second turns it back on, and then all is well.

 

Any idea what the issue is?

 

If it matters, the TV is an LG OLED65C7P. HDMI cable.

-- Ethan


check the TV to see if it has a firmware update. If it is up to day try changing the input HDMI that the set top box is connected. The set top box reboots overnight and it sounds like the TV is not recognizing the reboot power on. Recycling the standby should be the same 'active' signal on the current port. it is a TV issue unfortunately. Is there a receiver attached to that particular TV? or pehaps a sound bar?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
Frequent Visitor

Re: Once a day my TV says "no signal" but green light is on

Thanks for pointing out the reboot timing. That makes sense.

 

Unfortunately there is no firmware update pending on the TV, neither receiver nor sound bar either. The X1 box is connected directly to a TV HDMI port.

 

I'll try switching the port, although that seems unlikely. I guess I'll try asking on the LG website.

 

Official Employee

Re: Once a day my TV says "no signal" but green light is on

Take a look at the CEC settings of the tv
Expert
Moved:

Re: Once a day my TV says "no signal" but green light is on

Frequent Visitor

Re: Once a day my TV says "no signal" but green light is on

The CEC setting is OFF.