Community Forum

No signal for TV, but I can play DVDs.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

No signal for TV, but I can play DVDs.

My TV is turning on and once the white upside down V appears I get a message saying "No Signal" and then it goes dark. My DVD plays, but not the TV--no guide, nothing.

 

Silver Problem Solver

Re: No signal for TV, but I can play DVDs.

Reattach ALL your coax connections and then pull the power cord to the box and plug it back in and let it reboot.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: No signal for TV, but I can play DVDs.

Check that you are on the proper TV input.



I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: No signal for TV, but I can play DVDs.

As ComcastAndrew said, make sure that you are on the correct TV input. Is the box connected to the TV via HDMI or coax?