Community Forum

Netflix on X1 - jumpy video

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Netflix on X1 - jumpy video

When using the Netflix app through the X1 box I have noticed a jumpy/jittery picture on the British or foreign shows. All the other shows work fine. Have not seen another post on this issue. Has anyone else experianced this?

 

New Poster

Re: Netflix on X1 - jumpy video

I am experiencing this exact same thing. Planet earth and black mirror are jumpy via Netflix via Comcast X1 at times, clears up for a few seconds and then comes back. Have not found a solution however the same shows via Netflix on the Xbox are fine. Thinking it’s a Comcast issue.
Expert

Re: Netflix on X1 - jumpy video


astgeorge wrote:
I am experiencing this exact same thing. Planet earth and black mirror are jumpy via Netflix via Comcast X1 at times, clears up for a few seconds and then comes back. Have not found a solution however the same shows via Netflix on the Xbox are fine. Thinking it’s a Comcast issue.

is the 'jumpiness' on a companion set top box or on your XG2 (hub) or XG1 DVR?  if on a smaller box try same program on your DVR or HD (xG2) set top box.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: Netflix on X1 - jumpy video

We are also having the same problem watching the Crown and Last Kingdom. Both British productions I believe. Called both comcast and Netflix and neither had any idea what to do. 

Silver Problem Solver

Re: Netflix on X1 - jumpy video

Have you tried to watch it with a computer?

https://www.netflix.com/watch/80025757?trackId=13752289&tctx=0%2C0%2C


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.