Community Forum

Have triple-play but no TV services show up under my account

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Have triple-play but no TV services show up under my account

I have a triple play premiere package with all the premium channels. Everything works fine with my TV at home but when I try to log into xfinity.tv it will not let me watch anything, not the premium channels that I have or the basic channels. In fact it's like it won't even recognize I have a cable subscription at all.From below you can see that my internet and voice show up but not the TV.

I log in and can see all my billing info and everything looks fine but TV services just won't show up online. 

 

Please help!!!

 

http://xfinity.comcast.net/profile/

Shows the following.

Account Number:

Primary User ID: [ Loading... ]

Services: Internet, Voice Upgrade Services

My Device Information My Zip Code: 01040 My Cable Provider: Comcast New Springfield Digital My myDVR Manager Status: Not Installed My Set Top Box Names: Not Installed My Queue setup: False Facebook Queue Syncing: false Facebook Connect: False My public IP address: 71.235.171.109 My operating system: Windows - undefined My web browser: Firefox 14 - Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1 My system type: Desktop computer or other device My Move player version: Not Installed My Silverlight version: 5.1.10516.0 My flash version: 11.3 r300 Javascript: enabled Cookies: enabled
My Account Information Primary Account: True Provider Codes: a, c Internet Subscriber: True Cable TV Subscriber: False Voice Subscriber: True
Tags (1)
Silver Problem Solver

Re: Have triple-play but no TV services show up under my account

Hello,

Try setting up your boxes online to see if that will work.

Official Employee

Re: Have triple-play but no TV services show up under my account


smias99 wrote:

I have a triple play premiere package with all the premium channels. Everything works fine with my TV at home but when I try to log into xfinity.tv it will not let me watch anything, not the premium channels that I have or the basic channels. In fact it's like it won't even recognize I have a cable subscription at all.From below you can see that my internet and voice show up but not the TV.

I log in and can see all my billing info and everything looks fine but TV services just won't show up online. 

 

Please help!!!

 

http://xfinity.comcast.net/profile/

Shows the following.

Account Number:

Primary User ID: [ Loading... ]

Services: Internet, Voice Upgrade Services


You said "when I try to log into xfinity.tv it will not let me watch anything". What message are you getting when trying to watch a video? Is there an error message number also? 

 

Please tell me so I can further assist you.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe

New Poster

Re: Have triple-play but no TV services show up under my account

I am not getting an error message, it is simply saying I don't have a subscription for anything, even the basic cable channels as well as all the premiums.

I'm guessing this is because my cable isn't even showing up as a service under my profile, just internet and voice. It's as if I don't have any cable service at all according to xfinity.com even though I have the triple play.

It won't let me set up cable boxes online (even though it's currently working and showing all channels) either so I can't try that.

 

Services: Internet, Voice Upgrade Services

 

 

Official Employee

Re: Have triple-play but no TV services show up under my account


smias99 wrote:

I am not getting an error message, it is simply saying I don't have a subscription for anything, even the basic cable channels as well as all the premiums.

I'm guessing this is because my cable isn't even showing up as a service under my profile, just internet and voice. It's as if I don't have any cable service at all according to xfinity.com even though I have the triple play.

It won't let me set up cable boxes online (even though it's currently working and showing all channels) either so I can't try that.

 

Services: Internet, Voice Upgrade Services

 

 


Thank you for the information.

 

Our team is looking into your issue now. Someone will contact via phone within the next 72 hours. If they do not reach you, they will leave a message so please check your messages.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe

New Poster

Re: Have triple-play but no TV services show up under my account

Joe, 

 

Please inform your team I am having the same problem (I just have TV + Internet so my profile just says I have internet). I have called Comcast support 3 times today and no one has been able to offer a solution.

 

Thanks in advance.

 

Official Employee

Re: Have triple-play but no TV services show up under my account


kaefaux wrote:

Joe, 

 

Please inform your team I am having the same problem (I just have TV + Internet so my profile just says I have internet). I have called Comcast support 3 times today and no one has been able to offer a solution.

 

Thanks in advance.

 


Our team is looking into your issue.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe

New Poster

Re: Have triple-play but no TV services show up under my account

Thanks Joe. Whatever you guys did worked! Cheers for the quick (and effective!) response - I hope Comcast pays your more than they do their phone support people.

New Poster

Re: Have triple-play but no TV services show up under my account

Hi Joe, Im having the same situation. When i Log on to the mobile apps it says i need subscription, and I have the Triple Play package with premium channels. Please help
Official Employee

Re: Have triple-play but no TV services show up under my account


Opastrana wrote:
Hi Joe, Im having the same situation. When i Log on to the mobile apps it says i need subscription, and I have the Triple Play package with premium channels. Please help

Go to Xfinity.com/TV on a PC or Mac and then try playing the show or movie that you are trying to watch on the mobile app.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe

New Poster

Re: Have triple-play but no TV services show up under my account

Hello ComcastJoe, I'm also having the same issue and figured I would post in this thread as well.  

 

I have a new Triple Play service and am unable to sign-up for the HBO Go app.  I suspect it is because under "My Account" it also shows I only have Internet and Voice (and asks me if I want to add Xfinity TV).

 

I loaded up a video under HBO here and also have no problems viewing HBO on the TV thru the cable box. When trying to activate the app once I sign in on the Xfinity page it says I need to subscribe.  The two issues seem to be related??

 

Any help would be appreciated.  Thank you.

Official Employee

Re: Have triple-play but no TV services show up under my account


lunaticfringe wrote:

Hello ComcastJoe, I'm also having the same issue and figured I would post in this thread as well.  

 

I have a new Triple Play service and am unable to sign-up for the HBO Go app.  I suspect it is because under "My Account" it also shows I only have Internet and Voice (and asks me if I want to add Xfinity TV).

 

I loaded up a video under HBO here and also have no problems viewing HBO on the TV thru the cable box. When trying to activate the app once I sign in on the Xfinity page it says I need to subscribe.  The two issues seem to be related??

 

Any help would be appreciated.  Thank you.


Our team is further looking into your issue and will contact you shortly.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe

Frequent Visitor

Re: Have triple-play but no TV services show up under my account

I am having the exact same issues, I had triple play installed yesterday.

 

Only service showing up is the Internet...I need to set forwards online etc. and it basically marks as voice and tv services not available. And I should look at offers and purchase them.

 

However all services are working well, TV/Internet/Voice.

 

Please help.

 

Customer support just gave me a 5 call transfer run around - with no one able to clue in about what I was trying to say.

New Poster

Re: Have triple-play but no TV services show up under my account

Having the same issue right now, Xfinity TV and Voice are both not listed on my account as a service I have, even though I do have them. It is a bit unfortunate that I find this out on the first day of the NBC Sports extra live streaming of West Ham vs Cardiff City. Hopefully this gets resolved soon

Official Employee

Re: Have triple-play but no TV services show up under my account

It's should be on demand
New Poster

Re: Have triple-play but no TV services show up under my account

Having the exact same problem, profile only shows Internet but I have Internet + TV.