Community Forum

HDMI audio surround issue with X1 Arris MX011 box

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Expert

Re: HDMI audio surround issue with X1 Arris MX011 box


Trkarp wrote:
Did you ever get a solution to this? I have the exact same issue. I just traded my old Comcast box for a 'smart' X1. The old box passed through 5.1. The new one tries to determine via HDMI if it senses 5.1 and does not.

I am considering purchasing and HDMI splitter that may trick the X1 into seeing the 5.1 to pass through.

using your x1 remote select the Xfinity button > settings > Device Settings > Audio and look at the setting for HDMI audio output. is it set to auto detect? did you try the 'expert' mode to see it that worked?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
New Poster

Re: HDMI audio surround issue with X1 Arris MX011 box

Did you ever get a solution to this? I have the exact same issue. I just traded my old Comcast box for a 'smart' X1. The old box passed through 5.1. The new one tries to determine via HDMI if it senses 5.1 and does not.

I am considering purchasing and HDMI splitter that may trick the X1 into seeing the 5.1 to pass through.
Gold Problem Solver

Re: HDMI audio surround issue with X1 Arris MX011 box

As long as the X1 box continues to think your TV is stereo, I don't see a fix for this. Unless you do what I did. Get a different X1 box and run everything through a 3rd party TOSLINK digital audio switcher.
New Poster

Re: HDMI audio surround issue with X1 Arris MX011 box

My TV has the ability to set the audio for the optical out.  Choices are PCM, Dolby and DTS.  From my X1, the only choices on the TV are PCM and DTS (and Sonos doesn't support DTS).  From my Apple TV, the Dolby option becomes available and when I check the Sonos for what is being output it says Dolby.  So that proves it can pass it through but you're probably right that for some reason the box doesn't think so.  

 

My issue is with my setup, my box is in a closet and my HDMI runs through the crawl space so I can't connect an optical directly from my box to the playbar.  I have to use HDMI from the box to the TV.  So you think a new box will do the trick?

 

Gold Problem Solver

Re: HDMI audio surround issue with X1 Arris MX011 box

Swap your X1 box for one that has a digital audio output. Sounds like the XG2 is available in many areas now.

You may think your TV passes Dolby Digital 5.1 but your X1 box doesn't think so. FYI most TVs (including most Samsung sets) do not. Sony is the one noteworthy exception.

How do you know your TV is actually passing 5.1 audio from the Apple TV???


wjb2 wrote:

Thanks.  But my issue is actually a different one.  I don't have an optical out from my X1 box to my playbar.  The only audio out I have is via HDMI.  When I try to switch the HDMI output to 'Surround' is automatically resets to 'Stereo'.  It won't stick.  And when I check on my TV what the output is coming from the HDMI it says 'PCM'.  Again, I know my TV will passthrough Dolby because my Apple TV is connected via HDMI and it passes through Dolby to my playbar via optical.  So the issue is the X1 box HDMI.  And changing the settings doesn't work.





New Poster

Re: HDMI audio surround issue with X1 Arris MX011 box

Thanks.  But my issue is actually a different one.  I don't have an optical out from my X1 box to my playbar.  The only audio out I have is via HDMI.  When I try to switch the HDMI output to 'Surround' is automatically resets to 'Stereo'.  It won't stick.  And when I check on my TV what the output is coming from the HDMI it says 'PCM'.  Again, I know my TV will passthrough Dolby because my Apple TV is connected via HDMI and it passes through Dolby to my playbar via optical.  So the issue is the X1 box HDMI.  And changing the settings doesn't work.

Gold Problem Solver

Re: HDMI audio surround issue with X1 Arris MX011 box

The X1 box may say stereo in the settings but if you go into the audio settings and move the check mark to surround, the TOSLINK output will "override" the stereo setting and switch to DD 5.1. The X1 box may say stereo but it is actually outputting DD 5.1.

FYI this is discussed in detail in the final few pages of Neals audio thread...
New Poster

HDMI audio surround issue with X1 Arris MX011 box

I have been tracking message boards for days and have not found an answer.  I'm hoping someone from Comcast can help like Comcast Neal I saw on some posts last year.

 

My Arris MX011 X1 DVR box will only set its HDMI audio output to Stereo.  I have a Sonos playbar connected to my TV via optical that will only process Dolby surround (not DTS). I know my Samsung TV will pass through Dolby because my Apple TV is hooked up via HDMI to the TV and it will let me pass through Dolby.  So the issue is the X1 box, not the TV.  

 

I've read this box CAN output Dolby via HDMI so I don't know what to do.  Given the location of my box I cannot output optical directly to my playbar.  

 

So can someone PLEASE help me get a Dolby output via HDMI?!?!