Community Forum

HDCP Issues with Optoma HD141X projector

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

HDCP Issues with Optoma HD141X projector

So since switching to Xfinity from Uverse, I'm having HDCP handshake issues between my XG1v3 main box and my projector.  Every so often the projector will "search" for input for a few secs.

This doesn't happen with the PS4, doesn't seem to happen with Netflix via X1, but does with On Demand and I think recordings as well.

 

I had everything through an HDMI switch that has HDCP, but that didn't help. Now it's hooked up direct and still having issues.

 

The projector doesn't have component, so can't go that route without something to convert. I was thinking that maybe I could move the XG1 to another TV and take that box and hook it up to the projector as they don't have issues. Does the XG1 have to be hooked up directly to the modem (mine not rented)? Does the modem have to be in a specific location in the house?

 

Looking for thoughts/advice, as online research shows the problem is common but concrete solutions are iffy.

Official Employee

Re: HDCP Issues with Optoma HD141X projector

jesseweiss wrote:

So since switching to Xfinity from Uverse, I'm having HDCP handshake issues between my XG1v3 main box and my projector.  Every so often the projector will "search" for input for a few secs.
This doesn't happen with the PS4, doesn't seem to happen with Netflix via X1, but does with On Demand and I think recordings as well.
 
I had everything through an HDMI switch that has HDCP, but that didn't help. Now it's hooked up direct and still having issues.
 
The projector doesn't have component, so can't go that route without something to convert. I was thinking that maybe I could move the XG1 to another TV and take that box and hook it up to the projector as they don't have issues. Does the XG1 have to be hooked up directly to the modem (mine not rented)? Does the modem have to be in a specific location in the house?
 
Looking for thoughts/advice, as online research shows the problem is common but concrete solutions are iffy.

The modem has nothing to do with X1. You can move any of the boxes around but you'll probably run into the same error. It's your projector that may not be HDCP compliant.
Gold Problem Solver

Re: HDCP Issues with Optoma HD141X projector

I doubt it will solve the problem but if you have a Pace DVR you could try swapping it for an Arris or vice versa.
Gold Problem Solver

Re: HDCP Issues with Optoma HD141X projector

Andrew,

Not to disagree with you but the OP's projector is HDMI 1.4a so I would be surprised if it was not HDCP compliant. Unfortunately the spec does not mention HDCP.

We all know that X1 boxes can be a bit fickle and erratic to in their enforcement of HDCP... Especially with projectors.
New Poster

Re: HDCP Issues with Optoma HD141X projector

If the projector worked fine with a Uverse box until August, works fine with a chromecast, Roku, PS4, etc... then it certainly seems it is the box and not the projector. Otherwise I would have the same issues with those devices no?

 

As far as my research can tell, it's 1.4 compliant.

Gold Problem Solver

Re: HDCP Issues with Optoma HD141X projector

Need to make sure that your projectors firmware is up to date.