Community Forum

Cannot watch TV-MA shows online?

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Cannot watch TV-MA shows online?

Hello, I am going off to college and since I won't have access to a TV I've been trying to find ways to watch my shows online. Today when I was trying to watch "Game Of Thrones" online to see the latest episode it said that I could not watch it because the show is rated TV-MA. Well, I'm 18 and this isn't an issue. I am not the primary user but the person in my household who is has never set up a PIN for the Parental Controls. I can watch other shows that aren't TV-MA online with logging in through my email just fine. Why is this happening and can it be fixed?

Silver Problem Solver

Re: Cannot watch TV-MA shows online?

parental controls seem to set up on your account.  You need to have the primary user login and change that.

Regular Visitor

Re: Cannot watch TV-MA shows online?

I am the primary account manager, I have been trying to watch Longmire for 40 min. I keep getting the manage parental control message, which i have done a few times only to have the same message, what do I need to do on here? I tried removing controll, unlocking all to no avail. this is frustrating.

Frequent Visitor

Re: Cannot watch TV-MA shows online?

This is an issue for me as well. I tried it on Internet Explorer, Google Chrome, and Firefox. I've deleted all history and cookies. I've reset all browsers back to default (factory) settings. I've disabled all extensions on all browsers. I've "turned off" my parental controls. I even tried it with parental controls on but allowing all channels. My flash player is up to date. I have all current Windows updates installed. I'm running Windows 7 64-bit and Fedora Linux. I even tried using Internet Explorer 32-bit. It just gets stuck on the following;  
This video is rated TV-MA.
The following program is intended for mature audiences only.
Manage Parental Controls
It wont get past this page. I've tried it on multiple videos. This happened while trying to watch The Walking Dead. Please fix this ASAP Comcast!!!!!!! You might lose a few customers Smiley Sad. Right now I'm on Linux and it's happening as well. Here's more information with the computer I'm currently using;
My Device Information
My Zip Code:
My Cable Provider:
Use Dac:
My Conroller ID:
My Map ID:
My Persona ID:
My myDVR Manager Status:
Not Installed
My Set Top Box Names:
Not Installed
My Watchlist setup:
Facebook Watchlist Syncing:
Facebook Connect:
My public IP address:
My operating system:
Linux - Undefined
My web browser:
Chrome 33 - Mozilla/5.0 (X11; Linux X86_64) AppleWebKit/537.36 (KHTML, Like Gecko) Chrome/33.0.1750.152 Safari/537.36
My system type:
Desktop Computer Or Other Device
My Silverlight version:
My Flash version:
Enabled (1678 Bytes).
Time Information
My Clock Time:
Tue Apr 01 2014 16:18:39 GMT-0700 (PDT)
Server Clock Time:
Tue Apr 01 2014 16:18:39 GMT-0700 (PDT)