Community Forum

4K DVR and RDK-03004

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Frequent Visitor

4K DVR and RDK-03004

This is a long story, pardon me for that. I live in Chicago city. I was in my first apartment for 8 years and I have the tripple: Cable + Internet + Phone with a premium subscription of many channels and high speed net. In 2017 I moved to a new apt few blocks away and transferred all my services. Ever since I used to get the RDK-03004 error whenever there is a power outage or a refresh. I suspected some problem with the new apt connectivity.

 

Last week a comcast tech visited my apt and changed the splitter inside my unit (main cable comes into my unit and a splitter makes it two connections out, one to modem and one to DVR). He also cut the ends and crimped new connectors, reconnected everything, checked at the post outside etc. The problem seemed vanished. 

 

Since I have all 4K and HDR equipment at home and the DVR was almost 4 years old, I requested a DVR upgrade couple of days later. Xfinity sent me the new compact 4K DVR and I replaced it, the RDK-03004 came back again. I reconnected the old one and it was still working fine. After connecting between these two boxes back and forth a few times, I connected the old one and kept the new one turned-off, while requesting a tech visit. Today a tech came, reconnected the new one and he found the same thing. He connected the old one in the end, since it is the only one working and asked me to call Xfinity again for a second replacement. According to him signal is good. I am waiting for the second 4K DVR now, though I have a strong feeling that it is not the DVR but something else. Requesting help and assistance. What am I supposed to do if the second 4K DVR also shows the same thing?

Thanks

Jay

Official Employee

Re: 4K DVR and RDK-03004

Sorry you had to get that, there’s nothing that sticks out ast to the why, it just may be a bad box. I’m not sure why the tech couldn’t get you a replacement why he was there
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: 4K DVR and RDK-03004

Both the tech as well as the Comcast rep I called after told me that the 4K DVR should be sent from warehouse. Techs do not carry them as well as I cant get from the nearby Comcast customer center. So I have to wait another 3-4 days for it to arrive!

 

Thanks

Jay

Frequent Visitor

Re: 4K DVR and RDK-03004

After I ordered the second 4K replacement on 20th, there has been no updates. Comcast usually ships DVR the very next day and update us with a tracking, but this time no updates or no tracking. I called the customer care and no one has any information! This is really getting into my nerve!

 

Frequent Visitor

Re: 4K DVR and RDK-03004

OK I got my second 4K DVR and it is showing the exact same RDK-03004 error as the first 4K DVR. It is not the DVR, its the poor technical assistance that provided by Comcast. If you dont know what you are doing this happens.

I reported and asked for an escalation, waiting. If this doesnt work, I am done with the cable.

 

Jay

Tags (1)
Frequent Visitor

Re: 4K DVR and RDK-03004

While my old regular DVR still works, both 4K DVRs failed with RDK-03004 errors. I reported and they are sending another technician tomorrow. This time I am not accepting "your second DVR is also faulty, request a replacement for 3rd". So it is either solution or I am done with cable. Fingers crossed.

 

Thanks

Jay

Expert

Re: 4K DVR and RDK-03004


@JayTheDreamer wrote:

While my old regular DVR still works, both 4K DVRs failed with RDK-03004 errors. I reported and they are sending another technician tomorrow. This time I am not accepting "your second DVR is also faulty, request a replacement for 3rd". So it is either solution or I am done with cable. Fingers crossed.

 

Thanks

Jay


did you try swapping the 'new' with the old and see if the 003004 (low signal to comcast servers) moves with the box or stays with the outlet? what is your splitter/amp configuration?



I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: 4K DVR and RDK-03004

Today the technician arrived. So I had three boxes, the old working regular box and the two new 4K DVRs. He tried to swap them and everytime he connects the old regular box, it connects fine and we could see TV with all channels, in few minutes, as it boots and connects. But everytime he connects one of the new 4K boxes, it goes to the RDK-03004 error. He contacted his supervisor and Xfinity and no one could find anything. According to him signals are fine. He tapped a new cable from the post and tried to connect to a new 4K box and activate it, but failed. Finally he talked to someone and took both my new 4K boxes. They are going to try it in their facility (a Comcast center, I guess) and revert to me tomorrow. I have no idea whats all this about. I am waiting for their reply and arrival tomorrow. The old regular box is connected back now and it works as always!

So, as of today, the old regular box works fine again, so is the internet modem and my phone line. These three have no problems or no error codes as always. I get all HD channels as usual, I get around 200mb Internet and Phone. But no 4K DVR works as it goes to RDK-03004 error.

I don't know about any amp as I dont see any amp device or signal booster anywhere in my home or building or at the post. I have a regular splitter they installed at home, which splits one to Modem and one to DVR, which they changed and also tried to go around it (direct connection to 4K DVR, without splitter, which also failed).

I am really frustrated about it. I am sure it is something with the signal, nobody is telling me anything or they cannot find it out yet. 

Jay

Official Employee

Re: 4K DVR and RDK-03004

Jay the dreamer, thanks for your patience but if there was something wrong with the signal it wouldn’t matter what box went in. Stick with working with your local tech ops team, they’ll find the answer.
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: 4K DVR and RDK-03004

I agree, but then why is there a difference between the old DVR and the new 4K DVR? Same as what you said, the tech told me, as long as the signal is fine, it doesnt matter what DVR it is and they should see it. But the 4K ones always default to RDK-03004. Xfinity cannot see the device from their end and Tech at my end cannot activate it or do anything with it. 


As I told in the initial post, I moved to this Apt in 2017 after spending 7 years at my old place. I kept all the services and devices and just transferred it. Since there was no cable coming in to my unit, the day I moved an Xfinity tech came and put a new cable to my unit and he only connected all the devices then which still works. So I am not sure if that has to do anything with this, like a transfer of account, or anything technical related ot that. Or lastly the new 4K DVRs, are they not compatible with what Xfinity sends in terms of signal?

 

Anyway, I am waiting for couple of more days until they give me a solution or a final answer.

Frequent Visitor

Re: 4K DVR and RDK-03004

The technician came back with both 4K DVRs he took, connected one (which he marked as working) and now it is working. I asked about the root cause and resolution, but there was no clear reply. He just said they "activated" it at their center. If they were able to do that at their facility, why did it never worked from my apartment?

Anyway it is working now, I am glad the technicial put the extra effort. But I am not happy about the cause and explanation as I myself am a Systems Engineer.

 

Jay