Community Forum

xfinity stream beta on Roku premiere live tv

New Poster

xfinity stream beta on Roku premiere live tv

I have a x1 cable box installed and everything is working. In the bedroom I have a Roku premiere that reports excellent connection to my router. All the apps on the Roku work.

 

This includes the showtime channel and others. When I use the xfinity stream beta, on demand seems to work OK but when I try to watch live tv, it works for 20-25 minutes then either starts spinning or starts to get way out of synch and jumpy. I usually have to quit the app and restart it to fix this. Is this an issue with the xfinity stream channel or the Roku? I have unintalled and reinstalled the channel multiple times.

Has anyone else experienced this? I have also confirmed I am on the latest Roku and channel software.

Highlighted
Expert

Re: xfinity stream beta on Roku premiere live tv


@mburnham1973 wrote:

I have a x1 cable box installed and everything is working. In the bedroom I have a Roku premiere that reports excellent connection to my router. All the apps on the Roku work.

 

This includes the showtime channel and others. When I use the xfinity stream beta, on demand seems to work OK but when I try to watch live tv, it works for 20-25 minutes then either starts spinning or starts to get way out of synch and jumpy. I usually have to quit the app and restart it to fix this. Is this an issue with the xfinity stream channel or the Roku? I have unintalled and reinstalled the channel multiple times.

Has anyone else experienced this? I have also confirmed I am on the latest Roku and channel software.


the stream from your router is not enough when that happens to keep the stream beta channel connected.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!