Community Forum

Xfinity Stream on Roku Ultra works sporadically

New Poster

Xfinity Stream on Roku Ultra works sporadically

I have an X1 Box on one TV and Roku Ultras on all others.  I have zero problems with any app on my Roku with 150 Mbps (I actually clock in at 180 Mbps) WITH THE EXCEPTION OF THE XFINITY BETA FOR ROKU!!!  This app decides on its own when it wants to work.  When it does it is fine, but it will suddenly, and without a trigger, just stop working, or start stuttering, or simply disconnect with three dots ( . . .) running onscreen.  For a few days it was only the NBC channel that was having a problem - which is more than ironic considering who owns it. 

 

Is this App just bad or is there something else going on? 

Expert

Re: Xfinity Stream on Roku Ultra works sporadically


@Eandpatxfinity wrote:

I have an X1 Box on one TV and Roku Ultras on all others.  I have zero problems with any app on my Roku with 150 Mbps (I actually clock in at 180 Mbps) WITH THE EXCEPTION OF THE XFINITY BETA FOR ROKU!!!  This app decides on its own when it wants to work.  When it does it is fine, but it will suddenly, and without a trigger, just stop working, or start stuttering, or simply disconnect with three dots ( . . .) running onscreen.  For a few days it was only the NBC channel that was having a problem - which is more than ironic considering who owns it. 

 

Is this App just bad or is there something else going on? 


my roku is quite close to my 3 antenna wifi router and I've not had that problem. search for the xfinity channel (yes it is already installed) and look at the version and date available. the new version just came out a few days ago and may not have yet updated your roku.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Xfinity Stream on Roku Ultra works sporadically

I thought it might be a router problem at first but it happens on more than one of my Roku's in differnet rooms.  I will however see if the apps need updating  - thanks!!