Community Forum

Xfinity Stream app not playing anything on Roku

New Poster

Xfinity Stream app not playing anything on Roku

I have just connected my Roku to the TV and have added Xfinity stream beta as a channel. When I play other channels on Roku they play the content fine. When I try to play anything on the Xfinity Stream beta app, it buffers for a second then it will pause and reset the roku device. I have tried deleting the channel, resetting the device and reinstalling the channel and I have also tried a power cycle. Please let me know what else I can try. 

 

Thank you 

New Poster

Re: Xfinity Stream app not playing anything on Roku

You perfectly described the exact same experience I'm having and the troubleshooting I've tried. I've had the same TV, Roku, and service for over a year so not a thing has changed on my end. This just began happening here yesterday on 9/7 and continues.
Expert

Re: Xfinity Stream app not playing anything on Roku


@sabla102 wrote:

I have just connected my Roku to the TV and have added Xfinity stream beta as a channel. When I play other channels on Roku they play the content fine. When I try to play anything on the Xfinity Stream beta app, it buffers for a second then it will pause and reset the roku device. I have tried deleting the channel, resetting the device and reinstalling the channel and I have also tried a power cycle. Please let me know what else I can try. 

 

Thank you 


standard fix is to highlight the channel and press the * (star) button the roku remote and remove the channel. then unplug the roku from HDMI and from its power plug for 30 seconds or more. plug back in and reinstall the channel. be sure to approve the terms and conditions. now working?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!