Community Forum

Xfinity Stream Beta for Roku won't play DVR recordings

New Poster

Xfinity Stream Beta for Roku won't play DVR recordings

The Xfinity Stream Beta app for Roku has stopped playing any DVR recordings, starting in the last week or so.  When we try to watch any recording it pops up the message saying "You appear to have finished watching this recording.  Would you like to delete it?".  Choosing No does nothing and the message stays on screen. 

 

I've uninstalled the Stream from the Roku, restarted the Roku, reinstalled the app, and also physically power cycled the DVR.  The problem persists. 

Expert

Re: Xfinity Stream Beta for Roku won't play DVR recordings


@mike_wrong27 wrote:

The Xfinity Stream Beta app for Roku has stopped playing any DVR recordings, starting in the last week or so.  When we try to watch any recording it pops up the message saying "You appear to have finished watching this recording.  Would you like to delete it?".  Choosing No does nothing and the message stays on screen. 

 

I've uninstalled the Stream from the Roku, restarted the Roku, reinstalled the app, and also physically power cycled the DVR.  The problem persists. 


test: using the xfinity remote, start recording a show on tvland. when it completes, check the home DVR set top box and verify the entire recording will play. on the stream app look at the listing. do the lengths of the recordings match (approximately)?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Xfinity Stream Beta for Roku won't play DVR recordings

Hi Rustyben, I tried your suggestion.  I can record something on my DVR (and it actually shows as recording on the Roku while it's recording), I can watch the recording on the DVR, and the length of the recording matches between the DVR and the Roku.  It still won't play on the Roku and only prompts with the option to delete.  

 

I've also discovered that Xfinity On Demand stopped working through the Stream app on the Roku as well.  I can browse On Demand, but when I select something it tries to start playing and then goes back to the title selection screen for what I tried playing.  

 

Other streaming apps like Netflix, Hulu, Prime, HBO Go, etc. work fine on the Roku. 

Expert

Re: Xfinity Stream Beta for Roku won't play DVR recordings


@mike_wrong27 wrote:

Hi Rustyben, I tried your suggestion.  I can record something on my DVR (and it actually shows as recording on the Roku while it's recording), I can watch the recording on the DVR, and the length of the recording matches between the DVR and the Roku.  It still won't play on the Roku and only prompts with the option to delete.  

 

I've also discovered that Xfinity On Demand stopped working through the Stream app on the Roku as well.  I can browse On Demand, but when I select something it tries to start playing and then goes back to the title selection screen for what I tried playing.  

 

Other streaming apps like Netflix, Hulu, Prime, HBO Go, etc. work fine on the Roku. 


the roku believes it doesn't have the 'rights' to play the file. use the roku menu and navigate to the xfinity stream beta channel and press the * (star) button. from that menu remove the channel. go to the roku system menu and select restart (reboot) the roku device. when it comes back up, search for the xfinity stream tv beta channel and add it to your roku. reauthorize the xfinity app being careful to agree to the terms and conditions. will the recording play now? (this happened to me upon contract change a few weeks ago, days after new contract went into place).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!