Community Forum

Xfinity Stream App not working on any of my devices

New Poster

Xfinity Stream App not working on any of my devices

My Xfinity Stream App has been working perfectly the past few months but all of a sudden it stopped working on all of my devices (iPhone, iPad, MacBook). I can't watch any of my recordings or anything on On Demand. And even when I try to download my recordings, it'll start downloading but then suddenly go back to 0%. I've tried everything from signing out of the app and back in, closing the app, deleting the app and redownloading it, clearing my history, using different wireless networks. My Xfinity Stream is working on any of my devices even on the website version on my laptop. Please help!
Expert

Re: Xfinity Stream App not working on any of my devices


jmic wrote:
My Xfinity Stream App has been working perfectly the past few months but all of a sudden it stopped working on all of my devices (iPhone, iPad, MacBook). I can't watch any of my recordings or anything on On Demand. And even when I try to download my recordings, it'll start downloading but then suddenly go back to 0%. I've tried everything from signing out of the app and back in, closing the app, deleting the app and redownloading it, clearing my history, using different wireless networks. My Xfinity Stream is working on any of my devices even on the website version on my laptop. Please help!

your recordings and much of the on-demand library as well as the full set of TVgo 'channels' should be available. You might want to run the Xfinity My Account app and select the internet tab and make sure the modem equipment and serial number is shown as assigned to your account.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
Problem Solver

Re: Xfinity Stream App not working on any of my devices


jmic wrote:
My Xfinity Stream App has been working perfectly the past few months but all of a sudden it stopped working on all of my devices (iPhone, iPad, MacBook). I can't watch any of my recordings or anything on On Demand. And even when I try to download my recordings, it'll start downloading but then suddenly go back to 0%. I've tried everything from signing out of the app and back in, closing the app, deleting the app and redownloading it, clearing my history, using different wireless networks. My Xfinity Stream is working on any of my devices even on the website version on my laptop. Please help!

     Sometimes the app gets corrupted and you can try a cold reboot of your device then uninstall and then re-download and install. It has happened to me

     and that was the fix that worked. Good luck!