Xfinity plant
Community Forum
Xfinity globe

Caller ID not working on PC or iPhone

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Caller ID not working on PC or iPhone

I signed up for Triple Play 10 days ago and have spent hours on the phone getting things fixed. Caller ID is the last piece. On the iPhone app, the radio button for caller ID notifications is greyed out. On PC, I can run the app no problem -- but caller ID doesn't show up either place. Support says that UCID is enabled on my account.

New Poster

Re: Caller ID not working on PC or iPhone

caller id not working on pc or phone and i need to set up my phone for call forwarding and block private phome calls

 

Regular Visitor

Re: Caller ID not working on PC or iPhone

Call comcast & report it. If they can't fix it, call accounting & demand that you get the 20.00 credit on your next bill. I have done this  and have 3 times and have had 60.00 credit but they still haven't fixed the problem IM going for the 4th time. If enough of us do this they might try harder to fix the problem! 

New Poster

Re: Caller ID not working on PC or iPhone

Caller ID on the computer SOMETIMES works.  They have not yet worked out all the "bugs" in it.  It will work when I first log on, then it won't, then I uninstall and reinstall it on my computer.  Then it works and again doesn't work.....IT'S XFINITY.....do you really think anything is going work the way it is supposed to? LOL - good luck.  I've been battling this problem with them for MONTHS.

Highlighted
New Poster

Re: Caller ID not working on PC or iPhone

I recently returned for the season and my caller ID and call waiting on my landline are not working.  I spent 1 hour on hold with Comcast and they did not answer.  How do I reinstate these features?