Community Forum

VOD on Tivo: ""In order to start cable service..."

Regular Visitor

VOD on Tivo: ""In order to start cable service..."

A while back I replaced my Tivo with a new Tivo Bolt and moved my CableCard over to it; and called Comcast to get the CableCard configured and enabled on the new Tivo. Ever since, I haven't been able to watch any Xfinity On-Demand shows. Whenever I try Xfininity Video On Demand, all the shows on various networks show "In order to start cable service for this device, please contact your cable provider". I know as a fact that this used to work well before; and it was after switching to the new Tivo that this became an issue.

 

I called the # and spoke to someone, but the support person said that there was nothing they could do. I also called a CableCard specific number I got from a forum, and no luck. After calling multiple times tp Comcast with no luck; I figured it is worth a try posting here to see if anyone can help.

 

This has been going on for quite some time right now; and still no solution.

 

Official Employee

Re: VOD on Tivo: ""In order to start cable service..."

Hi ccspider, I have responded to your private message.

 

Thank you 

Regular Visitor

Re: VOD on Tivo: ""In order to start cable service..."

Thanks @ComcastPhill for helping resolve this issue!  I'm finally able to watch Xfinity VOD! Smiley Happy 

Official Employee

Re: VOD on Tivo: ""In order to start cable service..."

Hi ccspider, thank you for your patience with this but glad our team was able to help get your VOD working properly.  Please reach out if you have any questions in the future and we will gladly assist.

 

Thank you